Any example of Working Docker container?

Yes. this is my docker file

FROM sickp/alpine-node:8.11.0-r1
MAINTAINER Gary Ascuy <>

ENV BUILD_PACKAGES="python make gcc g++ git libuv bash curl tar bzip2" \
    NODE_ENV=production \
    ROOT_URL=http://localhost:3000 \

WORKDIR /root/app/bundle

ADD bundle.tar.gz /root/app
RUN apk --update add ${BUILD_PACKAGES} \
    && (cd programs/server/ && npm install --unsafe-perm) \
    && apk --update del ${BUILD_PACKAGES}

CMD node main.js

Also, this command I use for running the docker image

  1. docker run -d -e ROOT_URL=http://localhost -e MONGO_URL=mongodb:// -p 3001:3001 interviewcracker/app
  2. docker run -d -e ROOT_URL=http://localhost:3000 -e MONGO_URL=mongodb:// -p 3001:3001 interviewcracker/app

I tried both of them but Site is still not accessible.

Well, that says -p 3001:3001, so clearly that’s wrong.

Don’t detach, remove the -d command. Just let it print the logs. Remember, it’s not a machine, it’s a process. No wonder you haven’t been seeing them.

Otherwise, I have no idea. I build my image totally differently:

I’ve been using meteor for a long, long time so I’m not sure why things aren’t working, but I suspect you have something misconfigured at a basic level.

Ok, does it run fine with your docker configuration?

Also, Are you using the same command which I use to run docker image?

Check this its there in the active containers but its not opening

I tried to run other sample image like basic Hello world program. It also does not work on local, then I try to find the problem the problem is with the IP Address, So I tried this command --> docker inspect container_id to find out the IP address, the IP Address was provided by the output for this command is working with the same port I given in the run command.

When I tried to do the same with my App, there is different IP allocated this time (as expected). Then I tried to open the page, it says connection refused.

I also tried to find the logs using sudo journalctl -fu docker.service but this also does not have any error logs as such, here is the logs

Apr 25 08:20:41 bird-Lenovo-ideapad-310-15IKB dockerd[13300]: time="2019-04-25T08:20:41.707369627+05:30" level=error msg="ad35651e88d93ab880ac1ddddde46e8639405e6ee92b1a63584b6df5cf6387b3 cleanup: failed to delete container from containerd: no such container"
Apr 25 08:20:41 bird-Lenovo-ideapad-310-15IKB dockerd[13300]: time="2019-04-25T08:20:41.707565389+05:30" level=error msg="Handler for POST /v1.39/containers/ad35651e88d93ab880ac1ddddde46e8639405e6ee92b1a63584b6df5cf6387b3/start returned error: driver failed programming external connectivity on endpoint web-test (f6bc299dfd701b5e77303e17064d526f5d6949d34931a8230534117b28f3283a): Error starting userland proxy: listen tcp bind: address already in use"
Apr 25 08:21:25 bird-Lenovo-ideapad-310-15IKB dockerd[13300]: time="2019-04-25T08:21:25.243379997+05:30" level=info msg="shim docker-containerd-shim started" address="/containerd-shim/moby/2c928816cc863d91e1d4a08d31f8ead837ed578daeb56ee83997b70ea5e0cd68/shim.sock" debug=false pid=14890
Apr 25 08:29:25 bird-Lenovo-ideapad-310-15IKB dockerd[13300]: time="2019-04-25T08:29:25.749551747+05:30" level=info msg="shim docker-containerd-shim started" address="/containerd-shim/moby/eb0801ab8f528ddd37816571386d58ac19345b03d7a4b268d0ba8dc29e798cfa/shim.sock" debug=false pid=15846

Is there anything else I need to do for finding out why the IP address belongs to my app does not work?

@doctorpangloss Are you there?

@doctorpangloss, Thanks for your help. Really Appreciated your approach.

You were right, the issue was configuration & with force-ssl package used in the project.

Thanks man! I deployed the app using DOCKER. Wow!

In case you’re interested, here is the Dockerfile that I am using to run my production Meteor app, Strum Machine. Took some work to figure it out but works like a charm now.

I have Google Cloud Build automatically build Docker images when I git push to origin so all I have to do is wait for the build to complete and then deploy using the built Docker image in the Google Container Registry. :slight_smile:

More info in the readme.

1 Like

Mup deploys to docker and works great

Thanks will give it a try!!

Most of the people don’t know it uses docker internally