Deploy to galaxy on windows 11 fails (but works on windows 10)

I have three computers. Two with windows 10, and a new one with windows 11.

The windows 11 Pc for all I do fails to deploy to galaxy with the error below. A bcrypt thing perhaps…

My app builds and runs locally on all three.
All have node v14.18.2 and npm6.14.15.
Only the windows 11 rig fails every time, same error.
Both windows 10 rigs deploy flawlessly.
I have tried different node versions and reinstalling bcrypt, meteor, clearing out node_modules and the meteor folder.

No idea if it really is windows 11 causing this. As far as I know everything is the same save the OS… Anyone else?

Hi @theslantedroom, can you open a ticket on support@meteor.com providing your app hostname so we can check your logs?

Sure thing! just email that address?

yes, please do it.

Thanks.

Hi, have you checked this post?

I believe your problem is related to node-gyp on Windows 11.

Thank You! Trying it now, will report back!

I did try the things that post suggest but the issue remains identical. I wonder why I can build and run locally, but only once the galaxy server tries to install packages it fails…?

1 Like

Just wanted to re touch this… tried again and the issue remains the same. I thought after the latest updates maybe it would be fixed. Looks like still I have to bring old laptop travelling… :frowning:

Hi @theslantedroom, what steps are you using to deploy on Galaxy? Are you using the CLI or P2D?

I use cli. it works on my windows 10 pc’s. everything the same aside from the os.

sorry for the late reply, was away for a month.

We did some tests on the win11 machine, and it works.
Just one thing:

Only in the meteor installation with NPM that gave an error.
Because I had the antivirus (Kaspersky) enabled and it deleted several files from the Meteor, then I redid with the antivirus disabled, and it worked correctly.