Error: Cannot find module ‘@babel/runtime/helpers/builtin/interopRequireDefault’


#1

W20180804-14:11:24.192(8)? (STDERR) E:\meteor_project\app.meteor\local\build\programs\server\boot.js:475
W20180804-14:11:24.230(8)? (STDERR) }).run();
W20180804-14:11:24.231(8)? (STDERR) ^
W20180804-14:11:24.231(8)? (STDERR)
W20180804-14:11:24.232(8)? (STDERR) Error: Cannot find module ‘@babel/runtime/helpers/builtin/interopRequireDefault’
W20180804-14:11:24.232(8)? (STDERR) at Function.Module._resolveFilename (module.js:547:15)
W20180804-14:11:24.234(8)? (STDERR) at Function.resolve (internal/module.js:18:19)
W20180804-14:11:24.234(8)? (STDERR) at Object.require (E:\meteor_project\app.meteor\local\build\programs\server\boot.js:288:32)
W20180804-14:11:24.237(8)? (STDERR) at makeInstallerOptions.fallback (packages\modules-runtime.js:653:18)
W20180804-14:11:24.237(8)? (STDERR) at require (packages\modules-runtime.js:244:16)
W20180804-14:11:24.239(8)? (STDERR) at livedata_connection.js (E:\meteor_project\app.meteor\local\build\programs\server\packages\ddp-client.js:147:30)
W20180804-14:11:24.239(8)? (STDERR) at fileEvaluate (packages\modules-runtime.js:339:7)
W20180804-14:11:24.241(8)? (STDERR) at require (packages\modules-runtime.js:238:16)
W20180804-14:11:24.242(8)? (STDERR) at namespace.js (packages/ddp-client/common/namespace.js:1:300)

how to solve?
thanks


#2

I can help!
Copy “${path_to_app}\node_modules\@babel\runtime\helpers” (just files, not folder “esm”)
to “${path_to_app}\node_modules\@babel\runtime\helpers\builtin” (create builtin folder)


#3

thanks!
success!
but
Why is that?


#4

I really dont know))


#5

Second this, followed your fix, @wertyga.

cd into the app folder and then do:

mkdir $(pwd)/node_modules/@babel/runtime/helpers/builtin

cp $(pwd)/node_modules/@babel/runtime/helpers/* $(pwd)/node_modules/@babel/runtime/helpers/builtin/


#6

I did work! The error is gone…
but then I got another:
[1] W20180804-20:58:51.028(8)? (STDERR) TypeError: _interopRequireDefault is not a function
[1] W20180804-20:58:51.029(8)? (STDERR) at livedata_connection.js (/Users/dc/bn2/api/.meteor/local/build/programs/server/packages/ddp-client.js:149:22)
[1] W20180804-20:58:51.029(8)? (STDERR) at fileEvaluate (packages/modules-runtime.js:322:7)
[1] W20180804-20:58:51.029(8)? (STDERR) at Module.require (packages/modules-runtime.js:224:14)
[1] W20180804-20:58:51.030(8)? (STDERR) at require (packages/modules-runtime.js:244:21)
[1] W20180804-20:58:51.030(8)? (STDERR) at namespace.js (packages/ddp-client/common/namespace.js:1:300)
[1] W20180804-20:58:51.030(8)? (STDERR) at fileEvaluate (packages/modules-runtime.js:322:7)
[1] W20180804-20:58:51.031(8)? (STDERR) at Module.require (packages/modules-runtime.js:224:14)
[1] W20180804-20:58:51.031(8)? (STDERR) at require (packages/modules-runtime.js:244:21)
[1] W20180804-20:58:51.032(8)? (STDERR) at server.js (packages/ddp-client/server/server.js:1:14)
[1] W20180804-20:58:51.050(8)? (STDERR) at fileEvaluate (packages/modules-runtime.js:322:7)


#7

I reported the same issue in the Meteor project:

Version beta.56 of @babel/runtime lost the “builtin” folder. Going back to beta.55 removes the issue


Upgrade 1.7 Issue with @babel/runtime
#8

I tried on the following:
@babel/runtime@7.0.0-beta.55
babel-runtime@6.26.0

It didn’t work.


#9

TLDR: stay on 55, wait for a Meteor package patch

Here is the response from @benjamn from GitHub:

I will need to fix this when I update everything to 7.0.0-beta.56. In the meantime, you might want to stay on beta.55. The good news is that Babel 7 seems very close to its first release candidate!


#10

We have just release Meteor 1.7.0.4 to address this problem. Please run the following command in your application directory to update:

meteor update --release 1.7.0.4

If you see warnings about your @babel/runtime version, follow the instructions provided.


#11

thanks :grinning::grinning::grinning::grinning:


#12

Hi @benjamn,
I’m running meteor 1.7.0.4 and still seem to be running into this issue. When I start the app I see the following warnings with instructions to install @babel/runtime but I have already removed and reinstalled the latest babel runtime to no avail. My package.json shows a dependency on @babel/runtime version ^7.0.0. I tried removing and reinstalling again but of course see the same results:

Unable to resolve some modules:

  "@babel/runtime/helpers/builtin/interopRequireDefault" in /Users/jeffry/repos/DC/urma-auto-ui/imports/ui/app.jsx (web.browser)
  "@babel/runtime/helpers/builtin/extends" in /Users/jeffry/repos/DC/urma-auto-ui/imports/ui/app.jsx (web.browser)
                                              
If you notice problems related to these missing modules, consider running:
                                              
  meteor npm install --save @babel/runtime

any suggestions?


#13

Did you try pinning version 55?:

meteor npm install @babel/runtime@7.0.0-beta.55

#14

Yes, pinning version 55 works - but I thought Ben was suggesting the issue was resolved with 1.7.0.4 so that we could move up to the latest release version of babel. Am I misunderstanding that?


#15

The update in 1.7.0.4 just makes Meteor give a better error message with the instruction to pin version 55:

The version of @babel/runtime installed in your node_modules directory 
(56) contains a breaking change which was introduced by 
https://github.com/babel/babel/pull/8266. Please either downgrade by 
running the following command:

  meteor npm install --save-exact @babel/runtime@7.0.0-beta.55

or update to the latest beta version of Meteor 1.7.1, as explained in 
this pull request: https://github.com/meteor/meteor/pull/9942.

Change here: https://github.com/meteor/meteor/pull/10134/files#diff-40543a6d2858f1b8094f16c0cbe7c2cdR30

The full fix is in 1.8 (previously 1.7.1)


#16

Thanks for the info. Oddly I was running meteor 1.7.0.4 (I specifically checked) and the message you show above is not the same one I saw. Mine said nothing about using the beta version.

At any rate, I’ve reverted to the beta version and all seems well now. Thanks again.