Error: Cannot find module 'fibers'


#21

I had the same issue with fibers. This comment about a non-admin console solved my issue. I’m just starting with the tutorial, which runs from a non-admin CMD prompt or PowerShell but not an admin PowerShell.

Strangely, I don’t have the issue on another computer.


#22

Yesterday I had updated to the “April Windows 10 next big update - 1803” and after that I have same exact issue with fibers module. Tried admin and not admin cmd, reinstall meteor, reset meteor, update node. Nothing helps, that’s too bad.


#23

Same for me, the April update for Windows messed up completely all my Meteor applications with this error. Tried to reinstall Meteor using Choco, and install different versions of node, but nothing works for the moment.


Windows error in meteor
#24

Okay, so I used the bash Linux for Windows and it seems to work for me, if u want to try @targix.
What I did is open the bash, install nodejs LTS, mongodb, meteor and my Meteor applications started correctly without the fibers error.
In my first try I had some strange error:
Even with METEOR_ALLOW_SUPERUSER or --allow-superuser, permissions in your app directory will be incorrect if you ever attempt to perform any Meteor tasks as a normal user. If you need to fix your permissions, run the following command from the root of your project: sudo chown -Rh <username> .meteor/local

That was because I was using root ( If someone can explain me why there is a problem with it). So i just added --allow-superuser and it worked fine.


Cannot find module "fibers/future", on Win7
#25

It’s recommended to install as the user who will be using it. The installer will ask for your (sudo) password when it needs elevated permissions.

Problems are likely when you start trying to do stuff with Meteor as your normal user.

You should never use the root account for doing your day-to-day dev work!


#26

Hi @atf,
Could you break down the commands that you used ? I’m still new and I don’t want to mess up the installation process by doing something wrong . :slight_smile:
Thank you for your help.


#27

Hi @mostlyawesom,
I followed the same commands posted above by @SkyRooms.

sudo apt update

#Node.js LTS
curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash -
sudo apt install nodejs
sudo apt install nodejs-legacy
sudo apt install npm

#MongoDB
#https://docs.mongodb.com/manual/tutorial/install-mongodb-on-ubuntu/

#Meteor
curl https://install.meteor.com/ | sh

sudo meteor create test
cd test
sudo meteor
# add --allow-superuser if u have an issue with METEOR_ALLOW_SUPERUSER
# meteor --allow-superuser


#28

Ok, like many others I am facing the problem running my meteor app after the April 1803 Win 10 update. Started out with the fibers issue like everyone else. This was resolved by running the following commands in my app folder:

meteor npm uninstall fibers
meteor npm install fibers

This just led to the issue of: Error: Cannot find module 'underscore'

This is a meteor package version 1.0.10 which has not been updated in years. It points to underscore 1.4.2 and the current is 1.9.0 so it could really use some love.

Oddly, this package was not part of my build as I prefer lodash. Added this using meteor add underscore added it, but still produces the same error! Removed it again since there was no impact.

Wondering if that is causing issues. Other suggestions?


#29

Just to follow up, wasted most of my day yesterday and now have progressed to an error AGAIN in fibers:

c:\Users\xxx\meteor\yyy\node_modules\fibers\fibers.js:89
					return fn.apply(this, arguments);
					          ^
Error: EPERM: operation not permitted, stat 'c:\Users\xxx\meteor\yyy\.meteor\local\build\programs\server\node_modules'
    at Object.realpathSync (fs.js:1678:17)...

Highly annoying, Windows Meteor seems so FRAGILE! Took the exact code over to a Linux VM and fired up immediately. So, I think it it time to migrate over once and for all. Just need to figure out best way to share files between VM and Windows machine as I want to continue working on code in the Windows environment.


#30

#31

hi, actually I tried. but whenever I tried to edit the files in “AppData\Local\Packages\CanonicalGroupLimited.Ubuntu18.04onWindows_79rhkp1fndgsc\LocalState\rootfs\home” folder, it was displaying some permission error. files cannot be changed with bash running and after changes, I have to run chmod command every time I re-run the bash. so this is kind of problem on its own.


#32

put your files on your ntfs mount ( /mnt/c/ ) , you’re not supposed to access the linux file system from windows.


#33

I also did that. It throws an error that mongo exit with code 100.


#34

Yes , mongodb cannot run on the mounted ntfs , the hack is to create a symlink for the .meteor/local of your project to the linux home folder like this ln -s ~/myproject/local local


#35
  1. created a new project in /mnt/d/mtr/ank
  2. created ~/ank/local
  3. ran that command ln -s ank/.meteor/local/ /home/gysamy/ank/local

still not working. where’s the fault?


#36

ls -la in yourapp/.meteor folder shoud show the symlink like this

EDIT : you’re reversed your symlink I think , it should be ln -s ~/ank/local/ local , not sure about this , I’m not a bash killer :smiley:


#37


here take a look…


#38

something weird with your last ls -la , the local should be a simple folder without a symlink , and if it’s show it red it means that is broken. remove this one , and just create a simple folder.


#39

That’s because I specifically stated NOT to do that, EVER.


#40

From the official issue thread: https://github.com/meteor/meteor/issues/9863

It looks like a solution is on the way: