FlowRouter Errors w/ 1.3 upgrade


#1

Friend of mine who works in Meteor said his upgrade (for a similar project to mine) went fine, so I figured I would bite the bullet and try the upgrade as well, and I’m having some issues.

It seems flow router isn’t working at all anymore. Server isn’t throwing any errors, but page is not loading on client, and I’m getting 2 errors in console:

  1. Uncaught Error: Helpers dictionary has to be an object
    Template.helpers @ blaze.js?hash=38069f4…:3657Template.helpers @ alethes_pages.js?hash=8db1bea…:1335__Pages.Pages.setTemplates @ alethes_pages.js?hash=8db1bea…:636__Pages.Pages.clientInit @ alethes_pages.js?hash=8db1bea…:206Pages @ alethes_pages.js?hash=8db1bea…:174meteorInstall.lib.products_pagination.pagination.js @ pagination.js:5fileEvaluate @ modules-runtime.js?hash=939c79d…:158require @ modules-runtime.js?hash=939c79d…:92(anonymous function) @ router.js:70

  2. kadira_flow-router.js?hash=513a418…:509 There is no route for the path: /

Screenshot of my errors:

Any ideas on how to repair this? I don’t even know what to check…


#2

I am having this exact same problem. I’d love to get some help if anyone has figured this out.


#3

Looks like it’s not affecting many users… Guess we might have to troubleshoot ourself…

Since many flowrouter users seem to be functioning properly, I suspect it may be due to alethes pages alongside flow…

Do you happen to be using the pages package as well?


#4

Some people have been having the same problem in this other thread. Migrating to Meteor 1.3

I still haven’t found a solution though. Although some people are saying it’s realted to useraccounts package. I’ll keep you updated with any progress I have.


#5

Yes, I am using the pages package!


#6

Hmmm… We might be on to something here then. Sadly the pages package is not very well supported anymore, although there are some forks of it.

Might need to do some experimenting unless we can figure out an easy way to repair the error ourselves.


#7

Wow, good call. I just removed pages and commented out my pages code and my app is now working great.


#8

Ahh…

Well that’s awesome that we found the problem, but sucks as the Pages package is integral to my application, haha.

Guess it’s time to debug the Pages package.


#9

Hahaha oh me too. I have to have pages (plus it’s one of my favorite packages). At least we know that it’s the problem. Are there are forks of it we could try? I would also be happy to work on a fork with you that solves this problem.


#10

I saved a bookmark to this fork awhile back - https://atmospherejs.com/electronifiejs/pages

I have not tried it so I have no idea if it solves this error, and I’m still at work so I probably can’t fiddle too much with it until tonight/over the weekend.

(Edit: There’s also another fork out there, that’s supposed to fix some of the errors in the Pages package. But I did not save it and do not recall the name. If that one doesn’t work theres anotehr that may be worth trying!)


#11

@Spyridon the creator of pages just pushed a fix for the problem, if you update the package all should be working again!


#12

So I have the number 2) problem too, but I am not using Pages.
More thinking it is related to useraccounts:flow-routing, which does set up some routes, and in my case does that before the non-useraccounts routes are set up.


#13

I confirm I’ve the same problem with flow-router, and it keeps also removing useraccounts


#14

Thanks for letting me know. I gave the update another try today and was successful!


#15

Are you able to tell what you changed to make it work?


#16

The error was caused by the combination of the FlowRouter package w/ the Pages package.

Pages package was updated for 1.3, so now if you try to upgrade Meteor to 1.3 again, it should automatically detect the new Pages version, and error should be repaired!


#17

Ah, that was your 1) problem.
How about 2) in the OP?


#18

Both of those problems were fixed by the Pages package update. Pages was causing a conflict.

If you notice at the end of error 1, it has router.js included in the error chain. The first error was preventing FlowRouter’s functionality from being declared properly.


#19

Ok, thx. So for me that is not using Pages it is probably some other package with the same issue… Too bad I have 30 candidates to try :slight_smile:


#20

hmm… can you please try posting your whole error message (expanded if possible)? We can try to see what packages might be culprits by the files that are erroring!