Help test 2.3.1 RC

Wekan has a lot of features with current dependencies. I have tried to change from CFS to Meteor-Files https://github.com/wekan/wekan/pull/3273 but there is still issues in upgrade. I would like to upgrade to newest dependencies, but I don’t know how.

Most likely newest dependencies would work better and have less bugs.

Also there are so many forks at atmospherejs so I don’t know which ones of those work best.

Some kind of upgrade docs would be nice. Recommended newest dependencies etc.

This is a side effect of a major version bump. Painful in the short run with issues like these, but it can hopefully start the process of updating the code.

As for which versions feel free to ask. Now on atmosphere there are now verified checks for maintained packages and anything that has communitypackages in the maintainers list can be vouched for.

Do you mean these:

./models/server/ExporterCardPDF.js:        const fs = Npm.require('fs');
./models/server/ExporterCardPDF.js:        const os = Npm.require('os');
./models/server/ExporterCardPDF.js:        const path = Npm.require('path');
./models/server/ExporterExcel.js:    const fs = Npm.require('fs');
./models/server/ExporterExcel.js:    const os = Npm.require('os');
./models/server/ExporterExcel.js:    const path = Npm.require('path');
./models/users.js:        'The invitation code is required',
./models/users.js:        const Future = require('fibers/future');
./models/exporter.js:const Papa = require('papaparse');
./models/lists.js:import { ALLOWED_COLORS } from '/config/const';
./models/import.js:import { TrelloCreator } from './trelloCreator';
./models/import.js:import { WekanCreator } from './wekanCreator';
./models/import.js:import { CsvCreator } from './csvCreator';
./models/import.js:import { Exporter } from './exporter';
./models/import.js:import { getMembersToMap } from './wekanmapper';

Maybe these too:

./models/activities.js:export default Activities;
./models/lists.js:export default Lists;
meteor run android-device
=> Errors executing Cordova commands:

   While running Cordova app for platform Android with options --buildConfig,C:\the_app\.meteor\local\cordova-build\build.json,--device:
   Package type "bundle" is not supported during cordova run.

–packageType is not a valid argument for meteor run.
Unable to test android. Please advise.

Has been fixed in 2.3.2

@storyteller - Jan, you unfortunately didn’t post the link to the PR. I’m still getting the same error:

=> Errors while initializing project:

While selecting package versions:
error: Conflict: Constraint accounts-base@1.1.3 is not satisfied by accounts-base 2.0.0.
Constraints on package "accounts-base":
* accounts-base@~2.0.0 <- top level
* accounts-base@2.0.0 <- accounts-password 2.0.0
* accounts-base@2.0.0 <- service-configuration 1.1.0 <- accounts-base 2.0.0 <- accounts-password 2.0.0
* accounts-base@1.1.3 <- useraccounts:core 1.14.2 <- useraccounts:flow-routing 1.14.2

with the latest Meteor version so I guess it’s not fixed. Would like to monitor the progress of the PR, could you please post a link? Thanks, Jan!