Help with Meteor and MongoDB: Unexpected mongo exit code 100. Restarting

#21

Here’s the path that I have and what they contain, could you tell me what’s the one you’re talking about ?

C:\Users\Philippe\AppData\Local\lxss\home\Philippe
.config
.meteor
.nano
and other folders like these ones
C:\Users\Philippe\AppData\Local\lxss\mnt\c
Empty folder
C:\Users\Philippe\AppData\Local\lxss\rootfs\home
Empty folder
C:\Users\Philippe\AppData\Local\lxss\rootfs\mnt
Empty folder

The important thing to know is that folder lxss is not visible in the Windows UI, even if I checked the case to make hidden folders visible. And when I use the command line, I can go until this lxss folder and then, starting from home (and subfolders) I get a message saying that permission is denied.

#22

When I run ls .meteor/local/db in the test folder, here’s what I get : mongod.lock WiredTiger WiredTiger.lock WiredTiger.wt WiredTiger.wt.1 WiredTiger.wt.2

#23

Let’s take this one step at a time:

If you’re using WLS (Ubuntu on Windows) you don’t need to know or care about the Windows folders. In fact, generally speaking, you should forget they exist.

When you start Ubuntu you will be put into your Linux home directory. I suspect it’s something like /home/Phillipe/. You can check this with the pwd command:

pwd            (type this in)
/home/Phillipe (this is reported)

From that folder, try creating the default Meteor app:

meteor create demoapp
cd demoapp                 (you will now be in /home/Phillipe/demoapp/)
meteor npm i
meteor

and then in your normal Windows browser, go to http://localhost:3000 and check it’s working.

#24

Yes, it worked that time :tada: ! I think we’re closed to the final solution :slight_smile:

I did exactly what you told me, so I ran Bash on Ubuntu on Windows. You’re right, typing pwd returns home/Philippe.

I did the same with the terminal I usually use (Hyper), directly after opening it: /mnt/c/Users/Philippe is the result I get. I guess they’re not the same folder. If not, what’s the right path to go to /home/Philippe from Hyper?

Thanks a lot for your help man, you rock!

#25

As in https://hyper.is/?

I have no experience of that, but it’s available for Ubuntu, so if you want to use that in place of bash you’ll need to install it on Ubuntu - I’m pretty sure a Windows installation will not be what you want - and could be dangerous, as I mentioned in an earlier post.

My honest recommendation would be use bash in Ubuntu.

#26

Yes, that’s it!

I must stay on Windows for some professional reasons. Thanks a lot for your help, I’ll do more researches and will post my solution if I find one that suits my needs :wink:

#27

Then use PowerShell and a standard Windows installation of Meteor.

#28

This was the same my problem few month ago. (windows 7 64bit)
For my experience, this is one of two unaccountable big downsides when entering Meteor.

  • reasoning: somehow Meteor installs 32bit mongo db in 64bit OS
  • solution: use another stand alone mongodb
    => I wrote about this before:

  1. Symptom
  • It hangs on when “meteor run” for the very first example project:
    meteor mongodb “Unexpected mongo exit code 100”
    (Environment: windows 7 64bit, Meteor 1.5.1)
  1. Working solution
    ref:
    http://www.ryanmartinphd.com/meteor-on-windows-with-standalone-mongodb/
    =>
  • Setting environment variable MONGO_URL
    setx MONGO_URL mongodb://localhost:27017/meteor
  • Start another stand alone mongodb before starting program
#29

Sounds clean, someday I might try that with this.

#30

hey @zefifi have you ever found a solution to the mongo error? I installed linux subsystem and it doesnt work from my C drive I think its a problem with the formatting of the HD and permsssions. If I run it from the ~ home folder meteor works.

I am back using windows 10 meteor now but the linux version would be much better.

#31

I have the same problem with Meteor 1.8.0.2

Hope to find a fix quickly