No Directive annotation found on Socially

Getting the error “No Directive annotation found on Socially” in the console when I finish step 3 of the angular2-meteor tutorial… don’t know to resolve it, tried redoing the tutorial a bunch of time from scratch and still nothing… :confused:

1 Like

I am also facing the same problem when I replace Mongo.Cursor with NgZone,Tracker and all

i’m having the same problem

@deanox @prasadnpawar @sequintana
I explained here for the Socially tutorial:

See whether it helps.

1 Like

Hi Hongbo Miao,

Thanks you for the reply, you’re awesome!

Worked like magic, I am really new to meteor and angular and it’s nice to see there is support in the community, I hope I will be able to help someone else someday as well!

1 Like

Starting step 4 i encounter another issue, god be with me.

currently the tutorial is suggesting we should import platform/common like that:

import {APP_BASE_HREF} from ‘angular2/platform/common’;

It doesn’t work as expected:
client/app.ts (12, 29): Cannot find module ‘angular2/platform/common’

Do you have any idea what alternate import we should use in this case?

Thank you for the help!

Here you go:

import { APP_BASE_HREF } from '@angular/common';

1 Like