[RESOLVED] Showstopper! Signed Release Version APK not connecting to server!


#21

Yusssss :grinning: looks like abernix had fixed it just in time!!

BTW I am wondering why you have not moved to 1.4… it is quite faster…


#22

I have exactly the same issue. I just upgraded meteor to 1.4.2.7 and it doesn’t solve the issue. If anyone has an idea it would be great. :slight_smile:


#23

Do you use mup or meteor build?
What is your --server?
For your HTTPS website have you run an SSL checker?


#24

I use this command : meteor build ~/Downloads --server https://mydomain:443

I sign the release apk with : jarsigner -verbose -sigalg SHA1withRSA -digestalg SHA1 release-unsigned.apk myapp

When I check the logs on the server, I don’t see any connections related to my device with the signed apk.

When I run an ssl check I get : The certificate is not trusted in all web browsers. You may need to install an Intermediate/chain certificate to link it to a trusted root certificate.
I will check that.

It’s working well when I install the debug version or when I run it like that : meteor run android-device --mobile-server https://mydomain:443

EDIT : Ok I think it’s caused by the certificate (not correctly installed) as you mentioned it (Trust anchor for certification path not found.)
I’ll fix it and go back here :slight_smile:

EDIT 2 : Fixed with a correct SSL install ! :smiley: Thanks for pointing me in the right direction.