[SOLVED] - Can't run my meteor app

I just created a new meteor app (blaze) and when I try starting the app on terminal, I get this error

error while loading shared libraries: libcurl.so.4: cannot open shared object
file: No such file or directory
Unexpected mongo exit code 127. Restarting.
Can’t start Mongo server.

Here are a couple of things to try:

This is a new project I just created, so there is nothing in the database

but all the same, I have run the meteor reset all the same and it didn’t solve the problem

It just keeps showing "Unexpected mongo exit code 127

Hi @koakpet, can you provide the information below so I can help you figure out what is going on

Node version
Meteor version
OS and OS version
MongoDB version

What did you use to install Meteor and which command are you running

You are missing cURL you need to install the libcurl package you can get the sources via:

git clone https://github.com/curl/curl.git

But best to use your package manager, as I don’t know your distribution here’s all the ways you can get it (remember to run an update first to get the latest and greatest)

$ sudo apt update && sudo apt upgrade
$ sudo apt install curl

$ sudo pkg update && sudo pkg upgrade
$ sudo pkg install curl

CentOS / RHEL:
$ sudo apt-get install curl

$ sudo emerge curl

Suse: Install cURL on openSUSE using the Snap Store | Snapcraft


thank you so much

I use Ubuntu, immediately I ran the commands you shared, my problem was fixed :smiley:


Nice! You’re welcome man. Glad to be able to help!