[SOLVED] JSXSpreadChild error while processing ecmascript

@warehouseman same same. I had 6.x.x versions I just switched them all to ^6.20.0 types… :wink:

I do not use the badges (the project is private and not published) but I use https://www.npmjs.com/package/npm-check-updates and do my checks manually (very nice).

Good to know. I was not aware of that tool.

@warehouseman This one https://www.npmjs.com/package/npm-check even checks you es6 imports for missing deps and unsued packages! … I will have a look… :wink:

UPDATE: does not seem to play nice with meteor as it does not understand all the 'implied ’ modules from meteor… https://www.npmjs.com/package/npm-check-updates aka ncu works flawless for me… :wink:

then there are the Meteor package versions to worry about…

@warehouseman to be honest I rely more and more on npm. And the meteor packages are very stale… plus I do the meteor update from time to time…painless… :wink:


In fact, Meteor still has not failed you, has it?! It was something external, right?

Ultimately – Yes, we have to open ourselves up to the ‘npm’ maelstrom, but it sure was nice to be able to trust Meteor update.

Ok I found the exact babel plugin breaking everything:


I thought I’d go through all the plugins from the react preset one by one and see which one triggers the error… That is the one!

And there you go!

Armageddon Commit: https://github.com/babel/babel/commit/2bbc36d25e8b9bd0241896d74813bad448064c8b

Link to my comment on the repo:

So, I’ve discovered why I need the “react” preset – my mocha tests crash without it.

Currently, I depend more on Chimp Cucumber, so I don’t care all that much, for now.

Any idea of an alternative to --compilers js:babel-core/register ?

  "name": "meteor-mantra-kickstarter",
  "version": "0.2.1",
  "scripts": {
    "testonly": "mocha .scripts/mocha_boot.js client/**/tests/**/*.js --compilers js:babel-core/register",

@warehouseman good catch. I knew I needed the preset for something…Was so eager to get the app running that I didn’t care to run a batch of tests…Just tested meteor run/build :wink:

Just be patient. Have a look at the GitHub pull comments.
Maintainer is aware, we’ll probably get a fix very soon.
Seems a lot of people are impacted.

Just do like me , take the weekend off … :wink:

I have a thoroughly dopey workaround for keeping my CI green :

(don’t laugh)



The problem is solved. Just uninstall babel-preset-react and reinstall it!

You should have its babel-helper-builder-react-jsx dependency @6.21.1 now.
That fixed the error on my side.

More infos in the github pull request comments (link posted earlier here)

Have a nice end of weekend everyone!


├─┬ babel-preset-react@6.16.0
│ ├─┬ babel-plugin-transform-react-jsx@6.8.0
│ │ └── babel-helper-builder-react-jsx@6.21.1
│ ├── babel-plugin-transform-react-jsx-self@6.11.0
│ └── babel-plugin-transform-react-jsx-source@6.9.0

Well done @teknologist ! Thank you for your in investigation.
It’s OK for me about this issue.

I just have another issue to fix…

This also solved my problem. Thank you!