[Solved] Production Error: Mobx issue maybe? [Standard minifiers issue]

Hi all,

Getting the below error only on --production

  1. App works fine on local dev machine.
  2. App fails with --production flag, no errors thrown:


App does not work on galaxy either. Can someone give me some hints as to how I would go about debugging this? Any suggestions much appreciated.


Edit: So what is annoying is that there is no way to tell if is will work without building with the production flag. As you can imagine, this is getting old quick. Any suggestions would be appreciated.

Bump… + does anyone know how to inspect the build process with the --production flag, but a more verbose output? Thanks so much.


I solved this by switching the minifier. As per this, and this, and this, switching by meteor remove standard-minifier-js to meteor add abernix:standard-minifier-js helped.

Does anyone know what the issue is and what exactly is failing. That is, I fixed this issue by randomly trying stuff. Does anyone know why this is failing and what the actual problem is? i.e. am slow, someone please ELI5?

One of the threads says that using @abernix’s solution causes a failure in IE11 etc. Anyone know what the actual problem is?

Thanks so much,