The BIGASS self-hosted CONTINUOUS INTEGRATION comparison (Jenkins vs. GitLab CI vs. Buildbot vs. Drone vs. Concourse vs. …)


#22

Did you try BuddyWorks? Tried a few options and this one was really pleasant to use especially for a beginner like me :wink:


#23

@nicooprat Thanks for the hint. But I see that it only includes 120 free runs. Unfortunatley his is not enough for my project and small commit-habits. :grinning:

Still hanging with getting chimp to run on Gitlab (see above). Anyone got an idea what else to try?


#24

I’ve written about how to setup AWS codestar for Meteor. I’m not sure if and how it works with Bitbucket, but its for sure cheap…

At time of writing this guide it was still in an early stage though. Not sure how it is now


#25

@cloudspider Thanks a lot for the link. It looks really interesting… I might give it a try if my Gitlab efforts fail.

Current Status

With Gitlab I ran into 2 problems, which I am currently trying to fix:

  1. Chimp does NOT work https://github.com/TheBrainFamily/chimpy/issues/131
  2. XML reports are NOT reported via email and in the jobs-list of the user-interface. This is something I loved at CircleCi: Getting an email stating “10 tests fail. 190 tests passed" and then being able to dig deeper with a few clicks. Right now I am having problems configuring this on Gitlab. see https://forum.gitlab.com/t/10-tests-passed-190-tests-failed-how-to-setup-circleci-style-test-reports-possible-at-all/19093

Does anyone have a few hints? :smiley:


#26

@thebarty , you can refer to the dockerfile that I use for carrying out chimpy tests here https://gitlab.com/ziinc/barebones/blob/master/.config/dockerfiles/ci

Basically, it’s a docker file that extends an image with meteor installed, installing headless chrome and the necessary fibers build tools. you’ll need to register it as a repository image before using it on the CI runner.

The chimp config that you will need to use is here gitlab.com/ziinc/barebones/blob/master/.config/chimp-ci.js

You will also need to run both the meteor app and chimpy as child processes (as gitlab ci does not support background processes), so you will have to use the node script .config/ci-subprocess.js and run it with babel-node.

You can view the .gitlab-ci.yml used for running your user acceptance stage.

do note that chimpy (in it’s current version) still requires node v.8.x as fibers has not been upgraded yet.

Also, check out the npm script test-ci in the package.json to see how the node subprocess script is used.