Why is this happening? "Unexpected mongo exit code 100. Restarting."

I have just opened my terminal to start work. When I run meteor, I get the following:

=> Started proxy.                             
Unexpected mongo exit code 100. Restarting.   
Unexpected mongo exit code 100. Restarting.   
Unexpected mongo exit code 100. Restarting.   
Can't start Mongo server.                     
MongoDB had an unspecified uncaught exception.
This can be caused by MongoDB being unable to write to a local database.
Check that you have permissions to write to .meteor/local. MongoDB does
not support filesystems like NFS that do not allow file locking.
   Loading plugin `compileLessBatch` fro...  \

And it freezes, and the fan on my macbook pro goes crazy!

I have node.js twice in activity monitor - both at 100%…

chown -R $(whoami) .meteor/local

Try that.

it takes me back to my working directory…

when i try to run meteor, it has the same error again.

and now there is a third instance of node running at 100%…

sudo pkill node

Try that to kill all node processes.

ok, everything killed:)

terminal looks like this:

MacBook-Pro:youscream bruce$ sudo pkill node
MacBook-Pro:youscream bruce$ chown -R $(whoami) .meteor/local
MacBook-Pro:youscream bruce$

Does mongo think someone is messing with it and locked? Everything worked fine yesterday…

What happens when you run meteor now?

it has the same issue:(

It seems to be starting now when I type ‘meteor’, but then hangs - and outputs this:

Loading plugincompileLessBatchfro...

Does any one have any ideas for this?

Looks like you locked mongodb.
Try to remove this file .meteor/local/db/mongodb.lock

I get this pretty often. meteor reset solves it for me