1.0.4.1 crashing on modulus.io


#1

After upgrading from 1.0.3.2 to 1.0.4.1 and deploying to modulus the app is crashing. What can I do? The upgrade works fine on my local machine. But on modulus it seems to miss the latest Node. Thanks!

Meteor requires Node v0.10.36 or later.
[2015-03-18T20:20:10.871Z] Application CRASH detected. Exit code 1.
[2015-03-18T20:20:12.469Z] Application restarted.

#2

Set the Node version to v0.10.36. I don’t use Modulus, so I don’t know how to do this there.


#3

Looking through the docs I found this which should be enough to help you get your servers back up.


#4

Thanks @khamoud. Yes I had found the instructions on modulus as well, but I don’t know if package.json is set in the Meteor project (and where) – or if this is done somewhere else. Or if there is an entirely different approach.


#5

I apologize for being redundant then. I’m assuming that if you are using modulus that you are using demeteorizer? If so, look into your demeteorized version of your app before you push and in the top level you will find package.json which will have
... engines:{ "node": "0.10.33" } ...

which you should be able to manually change from there.


#6

Now I’m scared to deploy to my modulus server. Are you using the latest version of the modulus CLI?


#7

Updating to latest modulus tool will fix this issue.

npm i -g modulus

#8

Thanks @arunoda, updating the modulus tool solved the problem.


#9

Thanks @arunoda. Worked for me too.