1.3.4 breaks Galaxy deployment (ETIMEDOUT)


Note: Jamiter has a workaround below.

Have Galaxy deploys been down for over 12 hours for anyone else? Tried in a few different places and all we’re getting is “Error deploying application: Connection error (ETIMEDOUT)”

Announcing Meteor 1.3.4(.1) and 1.4-beta.1

May I ask what Meteor version you are on?


Running on the latest 1.3.4. We’ve tried several geographical locations and hosting centers to make sure it’s not a network glitch on our end, but it seems like Galaxy is the culprit.


Please see this GitHub issue, I think it is related:

I fixed it by setting the TIMEOUT_SCALE_FACTOR env variable to 10.

No response from MDG though, so not sure if it’s related, but it fixed it for me!


Thanks, that helped.


@juho - Thanks for reporting this.

We are aware of this and and are investigating the fix in this situation.

In the meantime, please use the workaround suggested by @jamiter or use a prior Meteor tool version to deploy to Galaxy.


Ok, updated first post to refer to the workaround :slight_smile:


Incident acknowledged and reported on our status page: http://status.meteor.com/


meteor update --release should work now—please confirm!


@benjamn this worked for me. Thanks!


@benjamn worked for me too


for me it’s the same on https://eu-west-1.galaxy.meteor.com

Error Deploying Application: Connection error (ETIMEDOUT)


Having the same issue when upgraded to v1.3.4 …


You can also upgrade to It is fixed in that release.


Can someone provide a copy and paste example of how to set the TIMEOUT_SCALE_FACTOR to 10 in terminal?
Thanks in advance


TIMEOUT_SCALE_FACTOR=10 meteor deploy example.com


Thanks for the help! I worked it around by downgrading the version to v1.3.3.1, and will try to upgrade to v1.3.4.1 soon!


Thanks! that did the trick!


omg, @jamiter is my new hero for figuring this out. THANK YOU