1.3 Problems - meteorInstall is not defined

I was really excited about getting started with Meteor for phone app development. But it already seems like things are unnecessarily difficult, and getting a BASIC Cordova app running is a problem. I’ve spent the last 3 hours just trying to build the project. I put my script dependencies in a lib folder inside the client folder and it would always freeze when building where I couldn’t even use Ctrl + C, but had to use some cryptic command to kill the process (new to Mac, in fact I got my first Mac specifically for Meteor development so this is frustrating to say the least). I read that this is a problem with 1.3. One guy said move the scripts to public folder and then embed them in the head. I did that, and it at least built. But then it appears to be making an app.js file and breaking on line 1.

In Google Chrome I get an error message regarding this line var require = meteorInstall({“client”:{“app”:{“pages”:…

Uncaught ReferenceError: meteorInstall is not defined.

Can anyone help me? It seemed that < 1.3 seemed to be better…

Otherwise it may be back to Firebase trying to learn their data structure and rules… :frowning:




Is there a way to downgrade to version ~1.2? I watched a couple different videos on Safari Books Online and it appears the concepts are no longer relevant…grrrr…

I’ve been having this exact same error, but only in Chrome. Seems perplexing.

I am upgrading my Meteor 1.2 project to 1.,3 and have hit a similar issue, but with a server - side application package.
It seems the Meteor code generator is not inserting a var meteorInstall = Package.modules.meteorInstall; declaration in the .meteor/local/build/programs/server/packages/my-package.js file, so that the following var require = meteorInstall({"node_modules":{"meteor": ... fails.

All works fine in 1.2.

** UPDATE: Found the problem. The meteor package package.js file did not add ecmascript as a dependency on the server. It worked OK after I added it:

  api.use(['ecmascript'], 'server');
  api.addFiles(['intercom-server.js'], 'server');

Maybe that was the root cause of your issue too? I have been hit by this same issue in my app-level packages (missing ecmascript dependency) several times after updating my app from 1.1 to 1.2, but each time it seemed to manifest itself in annoyingly - different ways.

I get the same issue (started happening when updated to in the compiled app.js file on the first line:

var require = meteorInstall({"client":{"components":{"layout":{"footer":{"template.footer.ng.js":function(require,exports,module){

Fix by @rsbatech is not applicable since it’s not a package that’s having issue, but the app itself.

1 Like

I’m seeing the same issue as rsbatech and cactusss. There was no problem when I upgraded from 1.2 to 1.3, but I’ve since tried 1.3.1, 1.3.2 and and keep getting this error.

1 Like

@rsbatech 's solution worked for me. An old package I wrote needed ecmascript server-side.

Having the same error as @cactusss since upgrading from 1.3.1 to

@sungwoncho I got my issue fixed. It looks like it got broken by “force updating” indirect dependencies.

@cactusss glad to hear you got your issue fixed, and you’ve given a pointer as to the cause - but what did you actually do to fix your issue please?! cheers

@andylorenz I still don’t know upgrading what exact package caused the issue. What I did is removed and re-added packages without force updating them.

I’ve got the same error a while ago with Meteor

In my case I’ve solved with $ rm -rf node_modules in my project folder, and then $ npm install.

Hope this helps.

I am also getting this error - haven’t seen any evidence of anything wrong with my packages

Uncaught refereceError: meteorInstall is not defined app.js:1

var require = meteorInstall({“client”:{“pages”:{“assignment”:{“questionItem”:{“template.questionItem.js”:function(){

fresh install of node_modules didn’t work for me… Is this a meteor package that has gone missing from my project? Anybody else experiencing this error? Not sure how to track this down as I wasn’t editing the code when my project stopped working.


This error is due to missing or inaccessible packages - somehow my package file was altered and I undid the change with git. Unfortunately I’m not sure what line actually caused the issue.

Just had this error with and found out my adblocker (uBlock) was the culprit. Disabling it on localhost allowed me to continue my development in chrome