1.5.1 EISDIR Error

I have created my app in Meteor 1.5 on Fedora 25.

Now I have installed Meteor 1.5.1 on Fedora 26 and I wanted to execute the same app.

When I start with meteor command in the old dir I get this error:

      throw error;

Error: EISDIR: illegal operation on a directory, unlink '/home/user/Dev/App/.meteor/local/dev_bundle'
    at Error (native)
    at Object.fs.unlinkSync (fs.js:932:18)
    at exports.makeLink (/tools/cli/dev-bundle-links.js:20:8)
    at [object Object]._.extend.ensureDevBundleLink (/tools/project-context.js:1504:7)
    at [object Object]._.extend._readFile (/tools/project-context.js:1438:10)
    at new exports.ReleaseFile (/tools/project-context.js:1388:8)
    at /tools/cli/main.js:898:22

I have checked and I have the same error on 1.5.0 also ;(((

Any help ?

Have you run “meteor npm install” again?

If i run meteor “meteor npm install” I get this error:

meteor npm install
    throw err;

Error: Cannot find module '../lib/utils/unsupported.js'
    at Function.Module._resolveFilename (module.js:325:15)
    at Function.Module._load (module.js:276:25)
    at Module.require (module.js:353:17)
    at require (internal/module.js:12:17)
    at /home/user/Dev/app/.meteor/local/dev_bundle/bin/npm:19:21
    at Object.<anonymous> (/home/user/Dev/app/.meteor/local/dev_bundle/bin/npm:92:3)
    at Module._compile (module.js:409:26)
    at Object.Module._extensions..js (module.js:416:10)
    at Module.load (module.js:343:32)
    at Function.Module._load (module.js:300:12)

so i think unsupported.js location has been changed.


with windows make sure your run 'as administrator`, and put your your meteor project in your documents folder, otherwise you get permission errors. With Docker this error also happens because of the symlinks in your bundle directory…

I use Fedora Linux.

I changed permissions with:

sudo chown -Rh user .meteor/local

But I still get the same error.