A method named '/${collectionName}/update' is already defined

I recently hit an interesting edge case: defining methods /${collectionName}/update clashes with predefined methods (insert and remove also clash). Relevant lines are

Hence, I have to name my methods differently. Any recommendation on method naming? I am now wrapping all methods in some object similar to what you can achieve with validated methods, so method names are not baked in as magic strings anymore. I do not want to allow calling a method by its name in code. Is it still advisable to give methods intelligible names?

If you avoid / (slash) you are going to already avoid these clashes.

Like links.insert for adding data to links :wink:

I already worked in a project using links#insert but I prefer .