Acceptance test in Meteor 1.3 cant find out why strange URL appears in Chrome


#1

I have installed Todos and it works fine. I could run unit tests, so browser showed result page.

But have stopped on acceptance test. I start Chimp and two things happen:

  1. Chrome browser is opened with data:, in URL
  2. There is error in terminal: “Unhandled rejection ReferenceError: Symbol is not defined”.

I use Ubuntu and Node.js 6.1

UPD Tried another Meteor project that has only one test. After starting Chimp watcher with Cucumber browser is opened again with data:, in URL. But with no errors in terminal.
UPD2 I think that solved problem with strange URL. Maybe this will help to someone.

  1. I have tried to run project from this great Tutorial. In console got error that saved me lot of time Error: [chimp] You need to install xolvio:backdoor in your meteor app before you can use server.execute(). So I install xolvio:backdoor package.

  2. I found this thread and downgraded Node.js to 5.11.0


#2

Did you find a solution for that? I have exact the same issue…


#3

Steps above fixed problem with URL. Besides this, you could also check version of Oracle JDK installed by running java -version in terminal. It should be not lower than 1.8


#4

For whoever runs into this strange matter:

Encountered this issue as well. After quite some research it seems to be related to this issue:

A Chrome issue prevents Chimp from running it seems. The fix in that comment solves the matter.