After Meteor Version upgrade getting " Assertion `args[1]->IsString()' failed" issue when starting the app

I upgraded my app’s meteor version from 1.7 to 2.11.0 but after this I’m getting Assertion `args[1]->IsString()' failed

is there anybody else who got this err after meteor upgrade ?


I got the same issue after upgrading meteor version :frowning:

Did you try to go directly from 1.7 to 2.11? That’s a big jump. Ideally, you’d go minor by minor…

I never saw this error before, but I did a quick search, and it seems that if you run npm i natives could solve the problem (source).

Could you try that?

@briankane You’re going to want to update in increments and see what builds. I would start with trying to update to 2.0 and work backwards, if it won’t build. Then slowly update forwards a couple of versions ahead each time. That is what has always worked for me at least.

we tried npm i natives but it didn’t work and nothing has changed…
I am triying minor by minor now

you are right I am starting to try from 2.0 now

1 Like

Worth the shot. But the best idea is to do as @trustydusty82 suggested, in increments.