After Upgrading to MacOS Sierra Meteor apps fail to start?


#1

Hello! Is anyone else having problems after installing MacOS Sierra?

All my apps now get stuck at “Starting your app” indefinitely (waited for 30+ min). I’ve tried Meteor reset to no avail and METEOR_PROFILE=1 METEOR_LOG=debug meteor --verbose doesn’t give any hints either.

Any advice?

Thanks,
-Kris


#2

After trying a bunch of random stuff what seems to have worked is to switch the iCloud Drive sync off and then on again. I assume some files were not synced properly which made Meteor fail to start.


#3

You run your Meteor app from iCloud Drive? Doesn’t that make your computer hot?


#4

MacOS Sierra uploads everything to the cloud by default which is where the problem started…


#5

No, it uploads your Documents, Desktop, and iCloud folders by default.


#6

yes, that’s where I had my “apps” folder. iCloud was trying to upload the bazillion small files that come with node includes and failing, meanwhile locking the folders themselves.

I only got Meteor working and restored access to my files by moving apps one by one to an external disk and disabling iCloud all-together.