Android app not registering with FCM or server when using raix:push package

#1

I want to have Push notifications in different mobile platforms and the browser and decided to use raix:push for that, which uses phonegap-plugin-push.

I followed the installation steps in README.md, which worked without problems and the project built and ran fine.

I followed the steps in ANDROID.md and added FCM to my project on console.firebase.google dot com/ (written down Sender ID and Server key). Then I created an app on play.google dot com/apps/publish and linked the Sender ID in the Services & APIs section.
At this moment I wasn’t exactly sure what else to do to make Google aware that my app is authorized to register for FCM. I tried uploading my apk in the internal test track channel, so it could see the config and signature in the apk, is that how it works?

Then I added the appropriate Push.configure and App.configurePlugin calls on the client as well as the Push.configure call on the Server.
To help debugging and fix potential problems, from here under the Server Code section, I added Push.debug = true, Push.allow(...) and a Meteor.methods(...) for debug output and triggering a notification sent from the server via the Browser console in the client (which according to Server logs is triggered).

On the Server logs, the Push registration seems to have completed (GCM configured log output), but on the client, even with Push.debug = true, I get no output on whether anything failed or succeeded except this on the server: Push: Settings userId "pwgsqhrBi29YFBspi" for app: X33KTY5yrfoM9CA9J
All I know is that the server doesn’t get a device which registers and says Push: Sent message "the title" to 0 ios apps 0 android apps, when sending a message through the Meteor.call.

Did I forget a step for properly registering my app with FCM and how can I further debug my problem?