Angular router failing with socially and meteor 1.3.4.1


#1

I was wondering if anyone had an idea of what is causing this app to fail:

I was having trouble getting the routing to work with deprecated so since the new one was updated in beta I decided to give it a try but I really have no idea how to parse the error I’m getting or whats causing it.

Uncaught TypeError: injector.get is not a function
[IH] bootstraping for http://localhost:3000/
[IH] Starting extension.
[IH] Browser type: chrome
[IH] Browser version: 51.0.2704.103
[IH] Local storage works.
[IH] This is not a hotel site, skipping
[IH] Vertical priority 0 ready to go hidden
[IH] This is not a travel operator, skipping
[IH] Vertical priority 1 ready to go hidden
[IH] This is not a rental site, skipping
[IH] Vertical priority 2 ready to go hidden
GET http://localhost:3000/service-worker.js net::ERR_INSECURE_RESPONSE


#2

look here https://github.com/Urigo/angular2-meteor/issues/305


#3

Thanks, so is there anything I can do or just wait? As of today it’s not working and that topics was closed 9 days ago.


#4

I had a similar issue with the socially tutorial using angular2. Not sure if you have run in to the same issue however the following fixed it for me:

meteor npm install --save @angular/core @angular/common @angular/platform-browser @angular/platform-browser-dynamic @angular/router-deprecated

The issue used to appear everytime I tried the following:
import { bootstrap } from ‘angular2-meteor-auto-bootstrap’;


#5

Is the new angular2 router much better than ui-router? I know the angular1-router wasn’t as good as ui-router.


#6

No sure I remember ui-router any more but the Angular2 router is much simpler and seems to be pretty straight forward. It’s a little more work than the deprecated one but seems more flexible. If I can get it working I’ll let you know!


#7

I got it working with this for now:
“dependencies”: {
"@angular/common": “^2.0.0-rc.4”,
"@angular/compiler": “^2.0.0-rc.2”,
"@angular/core": “^2.0.0-rc.4”,
"@angular/platform-browser": “^2.0.0-rc.4”,
"@angular/platform-browser-dynamic": “^2.0.0-rc.4”,
"@angular/router": “^3.0.0-beta.2”,
"@angular/router-deprecated": “^2.0.0-rc.2”,
“angular2-meteor”: “git+https://github.com/Urigo/angular2-meteor.git”,
“angular2-meteor-auto-bootstrap”: “git+https://github.com/Urigo/angular2-meteor-auto-bootstrap.git”,
“angular2-meteor-polyfills”: “^0.1.1”,
“core-js”: “^2.4.0”,
“es6-shim”: “^0.35.1”,
“meteor-node-stubs”: “~0.2.0”,
“reflect-metadata”: “0.1.2”,
“rxjs”: “5.0.0-beta.6”,
“zone.js”: “^0.6.10”
}