Announcing Meteor 1.4.1: Node 4.5.0, faster package downloads, and more


#1

As with most x.y.1 releases, Meteor 1.4.1 contains a number of incremental changes intended to polish and patch the recent 1.4 release. With that said, this release also contains some exciting new features that we will highlight below.


This is a companion discussion topic for the original entry at http://info.meteor.com/blog/announcing-meteor-1.4.1

#2

Congrats, but the most exiting text here is:

Meteor 1.4.2 will focus on improving rebuild performance,

Super excited, just why it took you so long? :slight_smile:


#3

Build performance is a difficult, many-faceted problem!


#4

Maybe I do not completely agree on such reasoning but understand and wish you best of luck! Doesn’t matter now - you are doing it hell yeah :heart_eyes:


#5

Any idea when we might see code-splitting? Initial page load has become disastrous in my app and we’re going to have to migrate off of Meteor if we don’t get code-splitting in the next few months.


#6

for new meteor, i like a workflow to upload to diferent servers, like mup but easy, official, and fast!


#7

very nice, the packages downloads are really faster. In my case, I’ve noticed that the rebuild is a little more faster than the previus version.


#8

Trying 1.4.1 already. Builds are lightning fasts. :smiley:

But facing one blocker regarding tests. :open_mouth: All the tests which worked till 1.4.0.1 stopped and threw errors after upgrading to 1.4.1.

Looks odd to me. I’m using dispatch:mocha-phantomjs. Anybody facing similar issue?


#9

So on MacPro OS X 10.11.6 it downloads and then seems to hang installing. Is there a way to enable debugging to know what is going on? This spinner is what I am staring at for the last 30 minutes

Downloading meteor-tool@1.4.1… /


#10

Great! Let me try it!

meteor update
Downloading meteor-tool@1.4.1...

(half an hour later)

Downloading meteor-tool@1.4.1...


#11

I tried to install 1.4 and gave up finally three hours later.
I could not install the Scss, sass pckagrs required for the meteoric package my app uses.
Did anyone manage to get this running?


#12

The blog entry says to re-install when it takes to long. Unfortunately re-installing removes .meteor and all the previously downloaded and installed versions and packages. Major PITA.


#13

For my medium size app I decided to go the clean way for upgrading:
( running on a Ubuntu 15.10 Desktop )

Filesizes before upgrade:

  • ~/.meteor folder : 8.4 GB ( yep, massive)
  • ~/Desktop/myproject/.meteor/local/bundler-cache : 212MB ( I had it cleaned out a few days earlier. But keep an eye one this one, it can become very large also. )

Upgrade:

  • rm -rf ~/.meteor
  • rm -rf ~/Desktop/myproject/.meteor/local/bundler-cache
  • reinstall meteor: curl https://install.meteor.com/ | sh
  • updated my meteor project with meteor update
  • Meteor asked to npm install bcrypt, which I did: meteor npm install --save bcrypt

Filessizes afterwards:

  • ~/.meteor folder : 1.2 GB ( still a hefty folder, but 7 times smaller)
  • ~/Desktop/myproject/.meteor/local/bundler-cache : 30MB

The whole proces of downloading, installing and upgrading was about 3 minutes.

BTW: My build-times:

  • changing a client-side file: about 3secs to rendered results
  • changing a server-side file: about 3secs to server restart
  • changing a method( which requires both server and client rebuild: about 6secs to rendered results

I don’t know, maybe I’m just lucky, but I have similar results on several apps ( small, medium and large-size). Even on my old laptop I get results after about 10-12 secs, and that one is running a virtual Ubuntu 16.04 on a Win7 Virtualbox host.


#14

yes, jamgold, i had that spinner for 4 - 5 long daaaaayz ! finally just completed the update. I have not updated in a long time, so maybe that was part of the issue (?)


#15

There have been a number of issues on github related to this issue, in a lot of cases it had to do with the CDN. Adding an entry into your hosts file for warehouse.meteor.com solved it for a lot of people.

Steps below:

  1. host warehouse.meteor.com
  2. edit /etc/hosts and put the IP from no. 1
  3. restart networking after no. 2

After 1.4.1 I’d assume it would be safe to remove the hosts entry again.


#16

Is anyone else getting the error “can’t reserve memory for parent stack” in Windows?


#17

Thanks for this update. Now I am back on the train, no more “downloading tooling”…I had to create a new meteor app and just copy my old files to the new directory and run ‘meteor add’ on all packages I used and now my app works perfectly as before. So far things really seem to work faster. Looking forward to future updates.
BTW I am on Windows 10 recently updated to build 14393.0. Also installed on Fedora 24, so far it works well too


#18

@benjamn re: the build tool, what about keeping the current build tool as a “starter” build tool for smaller apps, but make it very easy to switch to Webpack when build times become too slow?

The reason I ask is because from what I can gather, improving the build tool is far from trivial. So I just wonder if we couldn’t find a “shortcut” instead?


#19

I decided to create a new project and copy my old files over as digitalx778 did.

Though I also had to reinstall Python because I got the error message that it couldn’t find it.


#20

For build performance, I saw someone mention that disabling transpiling javascript for development would really speed things up. I think it’s a good ideA.