Anybody else seeing Mongo failures on hosted apps?

I have a test site I’ve been hosting on, and today using meteor logs I’m seeing errors like these:

[Mon Dec 07 2015 22:06:45 GMT+0000 (UTC)] WARNING Error: No primary found in set
[Mon Dec 07 2015 22:09:12 GMT+0000 (UTC)] WARNING MongoError: auth fails

Is anyone else seeing this? Is there a known outage, or is it more likely that I’ve broken myself?

Earlier today I could not meteor logs <mysite> - it just hung. Now I can’t deploy my app. meteor deploy <mysite> --settings settings.json came back with html saying “This site is down.” and “Try again later.”

Yes…very shaky availability last few days…

Yes, I’ve been seeing the same WARNING Error: No primary found in set errors today (as well as Error: No replica set primary available for query with ReadPreference PRIMARY) and meteor deploy is failing with the This site is down. HTML response. :frowning:

The issue, whatever it was, seems to be resolved (at least for my site).

I’m having exactly these same issues when trying to deploy to * since yesterday.
All works fine on localhost but not on the Meteor servers.

We also had lots of issues. Moved to a new server, so away from the * free hosting and now works without issues. So yes something has been wrong there but it’s not well communicated on so it’s not easy to find out the real reason.

@gatosaurio, @psavage, are you doing new deployments? My problems seemed to start when I did a meteor deploy --delete and tried to redeploy my app.

Also, does anybody know how we might make the folks responsible for hosting aware of these issues? I don’t actually know where to go aside from right here.

I just did another meteor deploy --delete and redeployed. I’d tried that before, but it worked today, so something must have changed. If you’re getting the auth fails error, you might try again now.

I have been having all sorts of issues since last night and still can not get my app to deploy…

The hosting isn’t launching my apps. I get ‘the site is loading’, timeout, retry.

And 5 minutes later it is back to working.

Yup, having lots of problems also. Mostly Mongo driver related.

Yep! Same here.

App can be deployed, but when I open it in browser - it doesn’t work.

Has any one heard any responses from the meteor staff about this issue at all?

The problem disappeared after deleting the app from the Meteor servers and deploying to another *.meteor com instance

We know they started to delete old apps from the environment which might be a related cause but that’s just a guess. Further no clear updates or communication seen. For sure not around these errors and also not on the status page. These issues occur already for days and days so there should be a notification on it for sure.

I have no problem with it being down - it’s a free tier, and I’m grateful to have that to test my apps with. So as long as it takes for MDG to get it back, it takes.

What does bother me however is MDG’s complete silence on the issue. Just a note to say “we’re aware of the problem and were working on it”, and maybe some detail on the cause, and expected time to fix if they cared to share that.

Just ignoring the various threads here hardly inspires confidence in their ability to handle issues with the paid service.


1 Like

@mbrookes, it looks like the people commenting on this thread agree with you. There doesn’t seem to be any hysteria or anger, just a little befuddlement.

Sorry if I gave that impression - I didn’t mean to suggest there was any (anger or hysteria). Just making it clear up front that I don’t have unreasonable expectations given it’s the free tier.