Anyone use meteorhacks:kadira recently?


#1

i recently came across meteorhacks:kadira and tried to use it (i.e. create an account, add the package, add the keys to my app). my understanding is that i could access a dashboard at ui.kadira.io/apps and i could get some insight into my app’s performance.

when my app starts, it says “Kadira: completed instrumenting the app”, but per their docs, i don’t see the authentication line.

i started a chat on their site 4 days ago but no one has even looked at it.

does this service still work? has anyone used it successfully in, say, the last week?


#2

Kadira had issues with their database. It seems fixed now.


#3

I have used Kadira. They do eventually look at the chats, but I have noticed that they are a bit slow.

When you start the app, do you see the line:

Kadira: Successfully connected

?


#4

It’s currently working for me. I’ve quoted @arunoda’s explanation of the recent downtime, below (was sent in an email to Kadira customers):

You may find, Kadira is down at the moment. That’s because, our database severs gone down due to an Google Cloud issue as we use Google Cloud to store our data.

There is no data deletion, but we cannot process new data. We are working on few work arounds for this issue and trying to come back online.

We are extremely sorry about the issue and I’ll inform you when Kadira is back online.

Even though Kadira is down, there is no effect to your running Meteor app. But, you’ll see some logs related to Kadira’s unavailability.


#5

here’s what i see when i start the app:

=> Started MongoDB.                           
=> Linted your app. No linting errors.        
I20160702-12:47:08.967(-4)? Kadira: completed instrumenting the app
=> Started your app.

=> App running at: http://localhost:3000/

so, no, i don’t see “Successfully connected”.

if the email quoted by @hwillson is current, then it makes sense that my data is not being processed. i think i signed up in the middle of this outage.


#6

Sorry, I should have included the date - I received that email on June 29th.


#7

i tried again, by doing “Create New” in kadira and getting a new set of keys. same behavior as before: my console tells me that the app has been instrumented, but i don’t see any confirmation of successful connection.

and no change on response to my chat window: “6d ago. Not seen yet.”


#8

this still isn’t working for me. my chat is now 3 weeks old, and no one at Kadira has looked at it. (it still says, “unseen”).

i don’t know what to do. others have said it works for them, and it does not work for me. and people there are still alive, as the chat tells me that Arunoda was active 3 hours ago.

what gives? i would be fired if i didn’t respond to a customer for that long.


#9

Yep, something isn’t working there. We have some time without any logged values, also I have some problems to access my dashboard.


#10

thanks for letting me know, @XTA. is it back to working for you, or can anyone else report issues?


#11

It’s working fine again


#12

i have tried yet again. i made a 3rd “app” on the free kadira service and loaded my keys. in the console, it says my app is instrumented, but i see nothing in the dashboard.

i can’t believe i’m the only one for whom this isn’t working.

and i STILL haven’t heard from them at all. started my 3rd chat today.


#13

I am experiencing the same as you Z - Kadira: completed instrumenting the app. Although I am deployed at galaxy, with keys in settings.json.

Is it working for you now, >2months after your last post?


#14

Nope, I gave up. Never got it working, never heard back from them. Feels like abandonware.


#15

Anecdotal, of course, but I’ve been using it regularly over the past week.


#16

Using it for months now, working without bigger problems (there was a small downtime withon the last 2 months).


#17

@vigorwebsolutions and @XTA - did you add only meteorhacks:kadira? did you add debug? kadira-profiler? Are you at Galaxy? did you deploy via settings.json? free version?

sorry for the question flash-flood, any info you could share about how you deploy would be much appreciated!


#18

We deploy via pm2-meteor (own vps servers) and also use Kadira Debug. We set the Kadira keys via settings.json and also use the free version.


#19

thanks @XTA, found my issue (operator error…). something about seeing you had done it via settings.json nudged me. i had nested the “kadira”:… keys etc within “public”. Once I moved it out I got data. thanks again!


#20

omg i actually got it working as well. i had my keys in the private section of the JSON. once i moved it outside there (i.e. not in public or private), it started connecting.

wow should that be made clear in the docs.