Apollo breaking on 1.4.2 upgrade

I’m trying to upgrade to 1.4.2 but Apollo is throwing with this error. I’ve tried to swim through all the npm installs needed and packages but am coming up short… any ideas? (also tried installing express-apollo for kicks but no luck)

Error: Cannot find module './expressApollo'
at require (packages/modules-runtime.js:109:19)
at meteorInstall.node_modules.graphql-server-express.dist.index.js (packages/modules.js:24624:23)
at fileEvaluate (packages/modules-runtime.js:181:9)
at Module.require (packages/modules-runtime.js:106:16)
at Module.Mp.import (/Users/adam/.meteor/packages/modules/.
at meteorInstall.node_modules.meteor.apollo.main-server.js (/Users/adam/Projects/Foo/main-app/.meteor/local/build/programs/server/packages/apollo.js:27:269)
at fileEvaluate (packages/modules-runtime.js:181:9)
at require (packages/modules-runtime.js:106:16)
at /Users/adam/Projects/Foo/main-app/.meteor/local/build/programs/server/packages/apollo.js:200:15
at /Users/adam/Projects/Foo/main-app/.meteor/local/build/programs/server/packages/apollo.js:206:3

package.json deps (thinned out to apollo deps)

  "dependencies": {
    "apollo-client": "^0.4.13",
    "apollo-server": "^0.2.8",
    "body-parser": "^1.15.2",
    "express": "^4.14.0",
    "express-apollo": "^4.13.7",
    "graphql": "^0.7.0",
    "graphql-tag": "^0.1.13",
    "graphql-tools": "^0.8.0",
    "graphql-typings": "0.0.1-beta-2",
    "http-proxy-middleware": "^0.17.1",
    "react-apollo": "^0.5.4",
1 Like

meteor npm install apollo-client@0.5.1
meteor npm install graphql-server-express@0.4.3

fixed things


@SkinnyGeek1010 Were you ever able to upgrade your meteor apollo package without getting this error?

@townmulti I was on the fence with switching languages so I ended up migrating to Absinthe for GraphQL instead.

Okay thanks! Found that meteor-starter-kit for for apollo doesn’t get the error.