Apollo + Casual issues


#1

My apollo server is chocking up the Casual package.

Error: Cannot find module './providers/address’
at require (packages/modules-runtime/.npm/package/node_modules/install/install.js:85:1)
at node_modules/casual/src/casual.js:44:1
at Array.forEach (/Users/dwaynecole/.meteor/packages/es5-shim/.4.5.12_1.1f4xtym++os+web.browser+web.cordova/npm/node_modules/es5-shim/es5-shim.js:435:21)
at Object. (node_modules/casual/src/casual.js:42:1)
at meteorInstall.node_modules.casual.src.casual.js (node_modules/casual/src/casual.js:70:1)
at fileEvaluate (packages/modules-runtime/.npm/package/node_modules/install/install.js:153:1)
at Module.require (packages/modules-runtime/.npm/package/node_modules/install/install.js:82:1)
at Module.Mp.import (/Users/dwaynecole/.meteor/packages/modules/.0.6.4.1c0dnmr++os+web.browser+web.cordova/npm/node_modules/reify/lib/runtime.js:70:16)
at meteorInstall.server.configs.seeds.mocks.js (server/configs/seeds/mocks.js:1:20)
at fileEvaluate (packages/modules-runtime/.npm/package/node_modules/install/install.js:153:1)


#2

I had the same problem – this version worked for me.


#3

I’m still having the same issue, with tried casual-browserify as well

Any new solutions?

package.json:

{
  "name": "name",
  "private": true,
  "scripts": {
    "start": "meteor run"
  },
  "dependencies": {
    "@babel/runtime": "^7.0.0-beta.51",
    "apollo-client": "^2.3.7",
    "apollo-client-preset": "^1.0.8",
    "babel-plugin-inline-import": "^3.0.0",
    "bcrypt": "^3.0.0",
    "body-parser": "^1.18.3",
    "casual-browserify": "^1.5.19-2",
    "date-fns": "^1.29.0",
    "express": "^4.16.3",
    "faker": "^4.1.0",
    "graphql": "^0.13.2",
    "graphql-server-express": "^1.4.0",
    "graphql-tag": "^2.9.2",
    "graphql-tools": "^3.1.1",
    "lodash": "^4.17.10",
    "meteor-node-stubs": "^0.4.1",
    "moment": "^2.22.2",
    "moment-duration-format": "^2.2.2",
    "react": "^16.4.2",
    "react-apollo": "^2.1.9",
    "react-dom": "^16.4.2",
    "react-map-gl": "^3.3.4",
    "react-router-dom": "^4.3.1",
    "semantic-ui-calendar-react": "^0.8.0",
    "semantic-ui-react": "^0.82.2",
    "styled-components": "^3.4.1"
  }
}