Apollo Error "_makeNewID"


#1

Hi there, I’m new to Apollo and I’ve been using the same method to set up my servers for the past few projects and it’s always worked until now. Today I’ve run into this error: Error: "_makeNewID" defined in resolvers, but not in schema, and can’t figure out why.

If the code related to pins is removed everything works fine, but when pins is included I get the error from above. Thing is, I haven’t defined that function in pin’s resolvers so I can’t tell why it thinks it’s there. I’ve figured out that _makeNewID seems to be from Meteor’s accounts collection, but don’t know where to go from there.

Here’s my API’s code:

import { createApolloServer } from 'meteor/apollo';
import { makeExecutableSchema } from 'graphql-tools';
import merge from 'lodash/merge';

import PinSchema from '../../api/pins/Pin.graphql';
import PinsResovler from '../../api/pins/pins';
import UsersSchema from '../../api/users/User.graphql';
import UsersResolver from '../../api/users/resolvers';

const typeDefs = [UsersSchema, PinSchema];
const resolvers = merge(UsersResolver, PinsResovler);

const schema = makeExecutableSchema({
  typeDefs,
  resolvers,
});

createApolloServer({ schema });

EDIT:
Removing PinsResolver from resolvers eliminates the error. Obviously, this isn’t a solution since I don’t have access to the resolver anymore. That said, PinsResolver doesn’t contain _makeNewID. Its content is as follows:

import Pins from './pins';

export default {
  Query: {
    pins(obj, args) {
      return Pins.find({}).fetch();
    },
  },
};

#2

You probably solved this by now, but I ran into the same issue.

I solved mine by correctly importing my resolver.

using your example:

import PinsResovler from '../../api/pins/pins';

change to

import PinsResovler from '../../api/pins/resolvers';