App builds but fails to render after new IMPORT statement

#1

Hello,

i am trying to implement the “meteor-mysql” package. I added the package via “meteor npm install meteor-mysql”.

I imported the package like so: import Mysql from ‘meteor-mysql’; (i tried variants with require aswell).

Now the app builds fine, but when i try to open it in the browser, i get the “no route definitions found” error from iron:router (see here https://i.stack.imgur.com/wEMbZ.png). This is not a problem with my routings, as they work fine without the import statement. My entire app works perfectly without that import statement (but of course the mysql part does not).

The strange part for me is that i can see with some logging, that the import actually worked.

Here is a snippet of my code:

var mysqlStringConnection = “mysql://test:test123@127.0.0.1/testapp?debug=false&charset=utf8”;
var db = Mysql.connect(mysqlStringConnection);
Test = db.meteorCollection(“test”, “testCollection”);
console.log(Test.find({}).fetch());

The console.log returns what it should return: the content of the “Test”-table.

I tried meteor reset and deleting the node_modules folder. Not sure, what i can do now. Not getting error messages either.

I really hope one of you can help me out here.

Best Regards
Chris