App not installed

Hi, I generated a apk file by running
meteor build ~/output-dir,
then got release-unsigned.apk in the folder output-dir, it looks good.

I copy this apk file to my Android phone and tried to install it, after install guide, it shows message App not installed.

I have installed some apk files built by java on my phone before, it works, so is there something I need handle when I install apk file built by meteor?

I did the extra steps of signing the app

keytool -genkey -alias your-app-name -keyalg RSA -keysize 2048 -validity 10000

and then

jarsigner -verbose -sigalg SHA1withRSA -digestalg SHA1 release-unsigned.apk your-app-name

but I still get the same “App not installed” when I try to install the apk.

I also tried

$ANDROID_HOME/build-tools/23.0.0/zipalign 4 release-unsigned.apk production.apk

Stil ‘App not installed’

I would suggest you to try to install app from ADB (connect your device and adb install app.apk) for me, I had this error “Failure [INSTALL_FAILED_UPDATE_INCOMPATIBLE]” so I removed the app with adb and then successfully installed it.