App not updating after Galaxy deployment


#1

I’ve just started using Galaxy and find I’ve had to do multiple updates/deployments to tweak in some fixes. I’ve noticed these updates get applied inconsistently if at all (at least short term, only been live for a couple days).

For example, I run a server side SyncedCron job that connects to an external api. I noticed that although the job ran at one point, it didn’t get any new data. No big deal, maybe there was no new data. So I edited the job details, added an additional schedule run about 30 minutes from the time I ran meteor deploy. Once the deployment was done, I see in the console logs that the new schedule run time is not set, it’s only showing the original schedule. I tried again, including stopping the app at Galaxy, but again, no change.

This works locally no problem after saving a change/restarting the (local) server

Another example is some basic client side html updates. I made the update locally, ran deploy, and saw now change. After about 10-15 minutes, the change did take hold.

Can anyone share info on the right process and expectations for updating deployments at Galaxy?


#2

Just wanted to share an update, after using Galaxy for a few more weeks I can say it’s definitely taking the updates without issue.