Arguments to path.resolve must be strings - minifying app stylesheet


#1

I tried to upgrade from 1.3.4.1 to 1.3.4.3. I am getting the following error.

While minifying app stylesheet:
path.js:313:15: Arguments to path.resolve must be strings
at Object.exports.resolve (path.js:313:15)
at Object.exports.relative (path.js:371:18)
at pathRelative (packages/minifier-css/minifier.js:205:1)
at packages/minifier-css/minifier.js:164:1
at Array.forEach (native)
at Function._.each._.forEach (packages/underscore/underscore.js:105:1)
at packages/minifier-css/minifier.js:122:1
at Array.forEach (native)
at Function._.each._.forEach (packages/underscore/underscore.js:105:1)
at rewriteRules (packages/minifier-css/minifier.js:99:1)
at Object.CssTools.rewriteCssUrls (packages/minifier-css/minifier.js:85:1)
at packages/minifier-css/minifier.js:55:1
at Array.forEach (native)
at Function._.each._.forEach (packages/underscore/underscore.js:105:1)
at Object.CssTools.mergeCssAsts (packages/minifier-css/minifier.js:32:1)
at packages/minifyStdCSS/plugin/minify-css.js:79:1
at CssToolsMinifier.processFilesForBundle (packages/minifyStdCSS/plugin/minify-css.js:17:1)



Removing standard-minifier-css standard-minifier-js seems to make this error go away. But I am not sure this is correct.

Can anyone advice please.


#2

+1, i have the same error! :frowning:


#3

I’m also getting this on 1.3.4.4. Is there an open issue for this on github?


#4

Not that I can find in the main meteor repo, but I don’t know if the minifiers have their own repos…?
(to be clear, I’m encountering this as well)


#5

I have the same problem, any solution found yet?

For now I downgraded back to 1.3.4.1,

meteor update --release 1.3.4.1


#6

Same problem. Downgraded for now, thanks @blocos for including the command for the quick fix.


#7

Update: An issue has been opened (thanks @workman)


#8

My problem turned out to be the package fuatsengul:leaflet. Once I removed that the error went away. It appears to already be flagged on atmosphere.


#9

This is because of a deprecated VML behavior url in the leaflet stylesheet.

I filed a pullrequest on bevanhunt:leaflet:


#10

@sewdn thanks for filing a pull request


#11

It has been merge in bevanhunt:leafletjs. Just update to 2.0.1.

If you are using fuatsengul:leaflet, I would suggest to file the same PR.

Kr


#12

Thank you @sewdn it solved my problem.


#13

I’m not experiencing this issue however I’ve closed the related Meteor issue since (from what I understand) this will be fixed by updating bevanhunt:leaflet.

As mentioned by others, those experiencing this should run:

meteor update bevanhunt:leaflet

…which should taken them to version 2.0.1 where this problem is fixed.

If I’m mistaken in closing this issue, please let me know! :slight_smile: