Atom ESLint Error


#1

I’ve followed the instructions in the meteor guide for setting up ESLint in Atom. But it’s giving me the following error:

Error: Failed to load plugin meteor: Cannot find module '../core-js/is-iterable'

Any idea on how to fix this?

thanks


#2

Are your eslint dependencies installed globally or locally? Are you on the latest versions?

I ran into problems before… I could only get it working by installing the modules with the g flag. I also had issues with the newest version of… the eslint module I think.

Take a look at the todos app. Whichever versions they have there, install those ones globally. That is essentially what I did if I recall correctly.


#3

I tried installing everything globally, tried using the versions in the ToDo’s app. Still no luck still getting the same error.

thanks for the suggestion though!


#4

Try searching your node_modules/eslint-plugin-meteor folder for core-js/is-iterable and make sure it exists (and not corrupted)


#5

is-iterable is in my node_modules directory, but it is not in the eslint-plugin-meteor/node_modules directory, how is it supposed to end up there? What is the best way of getting it in there? Should I just drop it in manually?


#6

I have it located at eslint-plugin-meteor/node_modules/babel-runtime/core-js/is-iterable.js

You may want to try npm i core-js directly


#7

I am only half kidding when I say this… but maybe try installing the npm modules with Yarn. Might “structure” the modules properly. Also lets you be cutting edge!