Babel what is required, where and why?

I am running into a problem with the atom-import-js plugin

I am running the latest rc171.5 of meteor

I get this message with meteor update
Newer versions of the following indirect dependencies are available:

  • babel-runtime 1.3.0-rc171.5 (7.0.0-beta.30 is available)

from meteor list --tree i see that babel-runtime is a depency of ecmascript@0.12.0-rc171.5

and the migration guide says:
meteor npm install @babel/runtime@latest meteor-node-stubs@latest

are in my meteor versions

@babel/runtime”: “^7.0.0”,
is in my package.json

It feels like babel is all over the place…

Where is it really needed and what is the best way to set up and update the project?

a atom-plugin should have nothing to do with your project’s babelrc. I think that is a misunderstanding.

to your message: “Newer versions of the following indirect dependencies are available:” comes from the meteor package manager, not from npm. so maybe call meteor update --all-packages ?

It could be a misunderstanding, the plugin maintainer suggested that i should upgrade my project to babel 7 or downgrade the plugin. Downgrading worked but I’d prefer to be able to stay up to date.

I’m not sure why the project babel version is relevant to the functioning of the atom import-js package, but thats what he said.

I thought I was running babel 7 (and I guess I am via npm/yarn), but Meteor has another version behind the scenes…

So now I am trying to understand the current state of Meteor Babel integration and what versions are relevant and needed… and does it make sense to run multiple versions?

Will the next (or future release of Meteor) upgrade fully to Babel 7?

Thanks for taking time to reply!