Bizzare data corruption on just one computer in our office[Solved - Don't use client side dates for important queries :D ]

So i have this big app we use internally (local server) for handling our client information / scheduling / etc

It has roughly 2 years of data in it- hundreds of clients, like 20+ employees and it basically just links everything up in an interface for easier month-to-month organization.

So it’s complex as hell, been dragged from meteor 0.4? (or so) and is currently 1.2. But it works, and well- i’ve never had to pull a backup of the database save for one user-error issue.

Recently the other day I had a co-worker say none of the info via his computer was loading correctly- and after looking into for a hour tonight it’s possibly the most confusing issue i’ve come across with meteor.

Every other machine in the office is fine, but for some reason his “monthly view” is only showing like 1% of the data it should.

Futhermore, logging in with different accounts, even installing a whole new fresh browser… restarting multiple times… checking his DNS and even Page File settings … nothing makes a difference- his computer will not show the right information.

Everything else in the office is fine- 10+ other computers, the app/server seems normal not one error, nothing weird in the database… even tried rolling it back a few hours (and once from a few days ago) … it’s almost as if his computer is some how blocked / not communicating fully with the server…

But stranger yet he can still manipulate data… add users and so on.

Is there anyway to be 100% sure his mini-mongo local storage is cleared / not-corrupt?

Could this maybe be a faulty hardware issue? RAM maybe?

Totally lost…

1 Like

Does sound like a mini-mongo issue to me. Did you try manually clearing cache for browser? Did it happen on different browsers?

I’m interesting in following this case as your software is intended for similar purposes as mine. Would like to be prepared if I run in to similar issues!

Yeah i’m wondering if it’s a mini-mongo issue too- however it’s affecting all browsers on his computer, wiped clean, even installed firefox that he’d never had… happening there too.

Local Storage (mini-mongo uses this afaik) isn’t somehow cross-browser right?

It’s strange because so far it appears to only effect April’s data… our system works month-to-month and if you select March or earlier it’s fine…

It’s almost as if something went awry with a document in April.

I’m going to also check into the Samsung RAPID mode that is on his computer, maybe it is a SSD/RAM caching issue somehow…

Are you using the client date in your application? Sounds a little bit like a wrong date on the client computer while using this wrong date for the current month.

1 Like

Glad you mentioned this because it would make perfect sense.

It was the first thing I considered since I’m using a couple extensions (bootstrap calendar / momentjs) for time/date managment.

This said- i convert everything to a unix timestamp and when querying for data I look at the first of the month + 1 month (using moment) -> covert it to unix and use the two values as a range to query with.

It’s never been a problem and I had confirmed yesterday that it was seeing April 1st no issue (with the right timestamp) but I suppose maybe the month+1 is messing up- I’ll do some debugging and see if it is seeing the end of the month correctly.

Also going to check out his actual time settings on there :confused:

I suppose it’s possible that a BIOS setting for the CPU might mess that sort of thing up too, maybe unlikely though.


His daylight savings time correct wasn’t selected (Windows 10) - this meant that all though he had his time set to say- 9am, somehow in the background it was still seeing 10am.

All of our data is saved at the first millisecond of each month- so the query appears to be running 1 hour ahead of that and thus missing it.


Going to refactor to server-only time probably… :smiley: