Brand new 1.3 project, meteor test doesn't work

Just to try out the testing in Meteor 1.3 I created a brand new project and ran the test command but I get:

$ meteor test --driver-package=practicalmeteor:mocha
[[[[[ Tests ]]]]]

=> Started proxy.
=> Started MongoDB.

Unable to resolve some modules:

  "browser/escape-string-regexp" in
/Users/sergiotapia/.meteor/packages/practicalmeteor_mocha/.2.1.0_8.njvjf6++os+web.browser+web.cordova/web.browser/mocha.js (web.browser)
  "browser/path" in /Users/sergiotapia/.meteor/packages/practicalmeteor_mocha/.2.1.0_8.njvjf6++os+web.browser+web.cordova/web.browser/mocha.js

  "browser/tty" in /Users/sergiotapia/.meteor/packages/practicalmeteor_mocha/.2.1.0_8.njvjf6++os+web.browser+web.cordova/web.browser/mocha.js
  "browser/diff" in /Users/sergiotapia/.meteor/packages/practicalmeteor_mocha/.2.1.0_8.njvjf6++os+web.browser+web.cordova/web.browser/mocha.js
  "browser/fs" in /Users/sergiotapia/.meteor/packages/practicalmeteor_mocha/.2.1.0_8.njvjf6++os+web.browser+web.cordova/web.browser/mocha.js
  "browser/events" in /Users/sergiotapia/.meteor/packages/practicalmeteor_mocha/.2.1.0_8.njvjf6++os+web.browser+web.cordova/web.browser/mocha.js
  "browser/debug" in /Users/sergiotapia/.meteor/packages/practicalmeteor_mocha/.2.1.0_8.njvjf6++os+web.browser+web.cordova/web.browser/mocha.js
  "browser/glob" in /Users/sergiotapia/.meteor/packages/practicalmeteor_mocha/.2.1.0_8.njvjf6++os+web.browser+web.cordova/web.browser/mocha.js

Consider running: meteor npm install --save browser

Even after running that command, I get the same result. Any thoughts?


same problem here! :frowning:

I get the same error message, but tests are still working fine. Checkout localhost:3000, you should see ‘Client tests’ and ‘Server tests’ titles. Also, I am adding --port 4000 so that I can run my app and tests at the same time.

Hopefully Meteor team is working on resolving the errors, but for now, this is working for me.

Right, I can see that page. Is there a way for me to run tests via terminal like in most other languages?

meteor test? for example
go test
mix test


Haven’t tried it but this might work:


@sergiotapia @bberto @topleft

After updating to meteor 1.3.1, the error is gone! Please check again.