Broke my app by moving it to another computer

I moved my app folder from one machine to another. I had to do a bunch of “meteor add …” when I tried to run the app. Now I’m stuck a this error:

triggers.js:100 Uncaught TypeError: triggers[lc] is not a function
    at Triggers.runTriggers (triggers.js:100:5)
    at router.js:184:18
    at Route.waitOn (route.js:298:7)
    at route._actionHandle (router.js:183:13)
    at ostrio_flow-router-extra.js?hash=623179b3d9ca70fd5b8611bd71c3a24dc6287a58:3611:52
    at nextEnter (ostrio_flow-router-extra.js?hash=623179b3d9ca70fd5b8611bd71c3a24dc6287a58:3435:7)
    at page.dispatch (ostrio_flow-router-extra.js?hash=623179b3d9ca70fd5b8611bd71c3a24dc6287a58:3441:7)
    at page.replace (ostrio_flow-router-extra.js?hash=623179b3d9ca70fd5b8611bd71c3a24dc6287a58:3406:34)
    at self._page.<computed> [as replace] (router.js:478:18)
    at page.start (ostrio_flow-router-extra.js?hash=623179b3d9ca70fd5b8611bd71c3a24dc6287a58:3294:10)

Can someone please help me get past this?

We need more information if we are to help. What version of meteor? Computer OS old and new?
Did you not have any .meteor files in your repo?

1 Like

You can try removing node_modules folder, running meteor reset and then meteor npm install --save

1 Like

Thank you. This put me on the right path.

Thank you! This solved the issue. Yay!