Browserslist: caniuse-lite is outdated

I get message

Browserslist: caniuse-lite is outdated. Please run next command `npm update caniuse-lite browserslist`

But I don’t have this package???

It is a peer dependency, often used by code quality tools like eslint. Please add your package.json and .meteor/pacakges lists to provide more insight in your app structure.

thanks for your reply.

  • NPM
{
  "name": "meteor-element",
  "private": true,
  "scripts": {
    "start": "meteor run",
    "test": "meteor test --once --driver-package meteortesting:mocha",
    "test-app": "TEST_WATCH=1 meteor test --full-app --driver-package meteortesting:mocha",
    "visualize": "meteor --production --extra-packages bundle-visualizer"
  },
  "dependencies": {
    "@babel/runtime": "^7.3.1",
    "@fortawesome/fontawesome-free": "^5.7.1",
    "animate.css": "^3.7.0",
    "axios": "^0.18.0",
    "bcrypt": "^3.0.0",
    "body-parser": "^1.18.3",
    "collect.js": "^4.6.1",
    "convert-excel-to-json": "^1.6.0",
    "decimal.js": "^10.0.2",
    "el-form-renderer": "^1.1.2",
    "element-ui": "^2.4.11",
    "express": "^4.16.4",
    "faker": "^4.1.0",
    "gitlab": "^5.0.0-rc.10",
    "inputmask": "^4.0.6",
    "jquery": "^3.3.1",
    "json2csv": "^4.3.3",
    "lodash": "^4.17.11",
    "mathjs": "^5.4.2",
    "meteor-node-stubs": "^0.4.1",
    "moment": "^2.24.0",
    "nprogress": "^0.2.0",
    "numeral": "^2.0.6",
    "perfy": "^1.1.5",
    "printd": "^1.1.0",
    "simpl-schema": "^1.5.5",
    "to-css": "^1.2.1",
    "v-money": "^0.8.1",
    "vue": "^2.5.22",
    "vue-avatar": "^2.1.6",
    "vue-barcode-scanner": "^0.6.0",
    "vue-clipboard2": "^0.2.1",
    "vue-count-to": "^1.0.13",
    "vue-data-tables": "^3.4.4",
    "vue-googlemaps": "^0.1.2",
    "vue-i18n": "^8.8.0",
    "vue-json-excel": "^0.2.98",
    "vue-json-pretty": "^1.4.1",
    "vue-markdown": "^2.2.4",
    "vue-meta": "^1.5.8",
    "vue-meteor-tracker": "^2.0.0-beta.4",
    "vue-outside-events": "^1.1.3",
    "vue-progressbar": "^0.7.5",
    "vue-router": "^3.0.2",
    "vue-types": "^1.3.4",
    "vuex": "^3.1.0",
    "vuex-router-sync": "^5.0.0",
    "xlsx-populate": "^1.19.0"
  },
  "meteor": {
    "mainModule": {
      "client": "client/main.js",
      "server": "server/main.js"
    },
    "testModule": "tests/main.js"
  },
  "devDependencies": {
    "@types/lodash": "^4.14.120",
    "@types/meteor": "^1.4.26",
    "babel-eslint": "^10.0.1",
    "babel-helper-vue-jsx-merge-props": "^2.0.3",
    "babel-plugin-syntax-jsx": "^6.18.0",
    "babel-plugin-transform-vue-jsx": "^3.7.0",
    "babel-preset-env": "^1.7.0",
    "chai": "^4.2.0",
    "element-theme-chalk": "^2.4.11",
    "eslint": "^5.13.0",
    "eslint-plugin-vue": "^5.1.0"
  }
}
  • Meteor
# Meteor packages used by this project, one per line.
# Check this file (and the other files in this directory) into your repository.
#
# 'meteor add' and 'meteor remove' will edit this file for you,
# but you can also edit it by hand.

meteor-base@1.4.0             # Packages every Meteor app needs to have
mobile-experience@1.0.5       # Packages for a great mobile UX
mongo@1.6.0                   # The database Meteor supports right now
tracker@1.2.0                 # Meteor's client-side reactive programming library

standard-minifier-css@1.5.2   # CSS minifier run for production mode
standard-minifier-js@2.4.0    # JS minifier run for production mode
es5-shim@4.8.0                # ECMAScript 5 compatibility for older browsers
ecmascript@0.12.4              # Enable ECMAScript2015+ syntax in app code
shell-server@0.4.0            # Server-side component of the `meteor shell` command

#--- Core ---
static-html
dynamic-import@0.5.0
ddp-rate-limiter@1.0.7
http@1.4.1
check@1.3.1
accounts-base@1.4.3
accounts-password@1.5.1
session@1.2.0
ejson@1.1.0
less@2.8.0
email

#--- Community ---
# Collection
aldeed:collection2-core
aldeed:schema-index
aldeed:schema-deny
matb33:collection-hooks
sakulstra:aggregate

# Method
mdg:validated-method
didericis:callpromise-mixin

# Path & File
ostrio:meteor-root
ostrio:files

# UI
akryum:vue-component
akryum:vue-less
akryum:vue-sass
cultofcoders:persistent-session

# Test
cultofcoders:mocha
xolvio:cleaner
mongo-decimal

Very likely a dependency or dependency of dependancy of akryum:vue-less or kryum:vue-sass

So it mean that, I must install npm update caniuse-lite browserslist?