Bug in windows installation


Can someone help me here…i am stuck here since 4 hrs.How much time it will take.
It is normal or it is a bug…starting your app is not completing


Have you tried restarting meteor / your computer / reinstalling meteor?


Can you show the exact commands you used to get to that point?


Yes i did this…


I had a similiar problem.

My workaround was

  1. starting local mongodb (you have to install one)
  2. set MONGO_URL=pathToMyLocalMongoDb in my case: set MONGO_URL=mongodb://
  3. start meteor


Thanks guys for your support…its really helpful
One more query i am facing

I have successfully started proxy and app …but thr is aproblem in mongo…i cant start mango…can u guyz help why i am facing this problem…please check screenshot…


You could delete your mongod.lock file. If it’s present and not empty, it may be that Mongo was not terminated cleanly and it thinks it’s already running.

In your example (using cmd.exe):

cd newpr
del .meteor\local\db\mongod.lock


HiThanks for the reply but it is showin
The system cannot find the file specified.


You absolutely should not need to install MongoDB yourself. The Meteor build tool installs a copy for you when it creates your app.

If you have installed your own MongoDB, you must ensure it’s running before starting Meteor and you will need to use the right syntax for setting MONGO_URL in Windows before you start it.

set MONGO_URL="mongodb://localhost:27017"



Mongo not started


If you’ve installed MongoDB yourself, you need to start it yourself before running meteor. Meteor will not start MongoDB for you if you’ve installed your own copy of MongoDB.

I use Meteor on Windows and have never installed MongoDB during development.

I think you have missed something during installation of Meteor, which is why I asked earlier:

Here’s the steps I followed:

  1. Install Meteor using the Windows installer.
  2. Open a cmd window.
  3. Type meteor create myapp.
  4. Type cd myapp.
  5. Type meteor npm i.
  6. Type meteor.

That’s it - no installing MongoDB - and no setting MONGO_URL.



This is all about my project


So that’s working - cool :slight_smile:

Browse to localhost:3000 to confirm.


No No

Mongo not started…
Listen thr are three steps

  1. Started proxy
    2.Started mongo
  2. Started app

*Mongo notstarted inScreenshot…please check again…this is my main prob…


No No

You have used set MONGO_URL="localhost:27107"

That means you are using an already running MongoDB.

You can see

=> App running at: http://localhost:3000/

That means it’s running.


Oh yes…very very thanks…


Hi One more
Now i am facing this problem

there is any problem in windows to run the meteor…should i move to ubuntu…?


Instead of set MONGO_URL="localhost:27107" use set MONGO_URL="localhost:27107/meteor". I forgot the database name needs to be specified if you don’t have an authenticated database: meteor is the name used by the standard dev builder, but you can use any name.


Oh…thanks again…


As per my observation, if Mongo Db was working fine and suddenly stops working, this problem occurs when we forcefully shut down our system with mongo and meteor services still running at back-end. So to prevent this, we should exit our services(or get out of meteor in simple words) before shutting down the system. Just my observation . Shared this hoping it will prevent few development hours that get wasted when people suffer from such things.