Can not build for Android. How to resolve?

I’ve got a Meteor app which deploys to iOS with no problem.

For Android, I run this:

meteor build --server=http://localhost:3000 ../../first

The above results in this:

**> Task :CordovaLib:compileReleaseJavaWithJavac** FAILED

FAILURE: Build failed with an exception.

* What went wrong:

Execution failed for task ':CordovaLib:compileReleaseJavaWithJavac'.

> Could not find tools.jar. Please check that /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home contains a valid JDK installation.

I can look in the applet’s package and see the contents of ‘Home’. It contains ‘bin’, ‘legal’, ‘lib’, ‘man’, and a few text files (‘copyright’, etc.). Does that mean it contains a valid JDK installation? I don’t know. Does it?

Earlier in the build process, I also get this (six times):

config file *-Info.plist requested for changes not found at /Users/{{my user}}/Meteor/{{my app}}.meteor/local/cordova-build/platforms/android/*-Info.plist, ignoring

How to resolve?

For similar problems, a bunch of SE posts exist that mention installing the same JDE as JRE. I did this.

Then I did this:

From that post:

Finally I copied tools.jar in /Library/Java/JavaVirtualMachines/jdk1.8.0_111.jdk/Contents/Home/lib/ to /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/lib/ and solved the problem.

I also removed an older JDK version in the same location under ‘JavaVirtualMachines’.

My JDK version was different, but the result was the same.