Cannot add package to project

How to fix.

METEOR@2.3.2

meteor add accounts-base accounts-password mikael:accounts-merge alanning:roles aldeed:collection2-core aldeed:collection2 aldeed:schema-index mizzao:user-status percolate:synced-cron cultofcoders:grapher akryum:vue-component akryum:vue-router2 dburles:collection-helpers froatsnook:sleep ostrio:logger ostrio:loggermongo simple:rest promise check

While selecting package versions:
error: Conflict: Constraint accounts-base@1.2.8 is not satisfied by accounts-base 2.0.0.
Constraints on package "accounts-base":
* accounts-base@~2.0.0 <- top level
* accounts-base@2.0.0 <- service-configuration 1.1.0 <- accounts-base 2.0.0
* accounts-base@2.0.0 <- accounts-password 2.0.0
* accounts-base@1.7.1 || 2.0.0 <- alanning:roles 3.3.0
* accounts-base@1.4.2 || 2.0.0 <- mizzao:user-status 1.0.1
* accounts-base@1.2.8 <- matb33:collection-hooks 0.8.4 <- cultofcoders:grapher 1.0.2
* accounts-base@1.2.0 <- simple:rest 1.1.1

Conflict: Constraint accounts-base@1.2.0 is not satisfied by accounts-base 2.0.0.
Constraints on package "accounts-base":
* accounts-base@~2.0.0 <- top level
* accounts-base@2.0.0 <- service-configuration 1.1.0 <- accounts-base 2.0.0
* accounts-base@2.0.0 <- accounts-password 2.0.0
* accounts-base@1.7.1 || 2.0.0 <- alanning:roles 3.3.0
* accounts-base@1.4.2 || 2.0.0 <- mizzao:user-status 1.0.1
* accounts-base@1.2.8 <- matb33:collection-hooks 0.8.4 <- cultofcoders:grapher 1.0.2
* accounts-base@1.2.0 <- simple:rest 1.1.1

Thanks.

Please read the Changelog, if you look around this has been addressed multiple times already:

Your problem is also clear in the error message you have posted. The version of simple:rest and cultofcoders:grapher that you want to use want to use accounts-base v1.x, while the rest of the codebase want to use accounts-base v2. Since this is a major version bump it won’t be allowed.

Sometimes if you are updating from old versions, you’ll need to do two things:

  1. Delete .meteor/versions file
  2. Go through .meteor/packages and remove the @X.X.X versions from the end of package names.

The meteor package constraint resolution system is not always helpful, and sometimes gets in it’s own way. I really wish Meteor would dump it, and go with npm, so that we don’t have two different module resolution systems any more.

downgrade to version “METEOR@1.12.1” is ok.

Thanks.