Cannot build android app anymore: crashes on opening app

Meteor 1.8.2. I try to open the app on the simulator or real device and it crashes before showing any splash screen. “The app has stopped”

Both locally (meteor run android) and when talking to staging server (meteor build).

If I use another computer to build the app from the same source, it works (both macbooks 2015~2016)

I tried

  • older versions of the same app
  • deleting cordova-plugins
  • removing and adding platform
  • meteor reset
  • removing cordova cache
  • downgrading Android Studio and Platform Tools
  • deleting the entire project and re-cloning from github
  • running the emulator directly with verbose log ($ emulator @Nexus_4_API_27 -verbose; I get logs as the emulator starts up but nothing when I open the app and it crashes)
  • reinstalled meteor

If anyone has any clues how I could diagnose this I would be grateful.

I also tried copying the entire Android SDK folder from the other computer, without success.

Eventually, some combination of the following seems to have solved it

  • changing back to the previous Android SDK folder
  • updating to the latest patch of Platform Tools and SDK Tools
  • updating Meteor to the latest version 1.10.2 (which includes a cordova update compared to Meteor 1.8.2)

Have you tried to debug it in Android Studio to see the actual crash logs?

Thanks for your response! How do I do this?