Cannot build with Meteor 1.5

I was using and everything was working well so I decided to update to, tested again and working (I don’t think it supposed to be many changes anyway).

So after this I updated finally to 1.5 and again all worked. I also updated all my dependencies.
Only when I was going to update my app version on the Android Market I just figured out that I couldn’t build it. This is the command that I normally use:
meteor build ../output-build --server --mobile-settings ./imports/settings.json

It starts to do everything but at some points it stops with no reason. Can’t see any output.

I normally compile on Windows, on which I’ve got this problem. I just tried on Mac and I see this error:
Requirements check failed for JDK 1.8 or greater
But this is ok because I had this error before as well so that’s why I always compile on Windows (I don’t want to download the whole Android on my Mac).

Resuming: I can’t compile on Windows using Meteor 1.5 (it stops with no errors)

Edit: I fixed the Mac issues with Java just to see if it still failing without any error and it does, the same problem that I’ve got on Windows

Running the previous command with --verbose I see that it always stops after this line:
Local package version is up-to-date: webapp-hashing@1.0.9

Hi Daniel! @erperejildo!

Do not try build the Android version app on Windows; use linux, like Ubuntu, for example.


Well, I work with Windows and that’s a supported OS so it should be ok.
However, I fixed it removing the .meteor/local folder and trying again,

1 Like