Cannot open mongo db console - Windows10 - SOLVED

Hi all,

I’m new to Meteor and trying to follow the getting started todo app tutorial.
https://www.meteor.com/tutorials/blaze/creating-an-app

I am stuck on step 3.Collections.

When I type meteor mongo it exits with a message about 32 bit deprecated.
And thus I cannot view or update the collections.

Any ideas how to proceed?

I’m on Windows10 64 bit

That’s perfectly OK (at least it’s OK for development purposes as long as you don’t need over 2GB data). It has no impact on viewing or updating collections, so if you’re unable to do that there’s something else going on.

If you do need a 64-bit MongoDB for development, you can install it separately and use that with Meteor, but it does require a little more work than the inbuilt MongoDB.

Hi Rob,

Thanks for the response.It’s not the size that bothers me - for now I am just trying to follow the tutorial.

When I run the meteor mongo command I get the messages as attached in original post, but do not get a console anywhere that I can see. So I cannot update the collection.

I.e. I don’t see how to perform these steps.

meteor mongo
This opens a console into your app’s local development database. Into the prompt, type:
db.tasks.insert({ text: "Hello world!", createdAt: new Date() });

No console opens that I can see and even tried typing the command in the git bash after running meteor mongo

Confused.

Ah, I see.

You need to leave that cmd window running - don’t do ctl-c, ctl-c. Then open another window and cd to the same directory to do the meteor mongo command.

Yup, that’s what I am doing.

I have the app running after typing
meteor

Then in another window I type:
meteor mongo

There is where I get the 32 bit message.

I’m not sure where I now enter the insert command. I am missing something obvious?

Someone in Gitter has suggested I try installing:
https://atmospherejs.com/msavin/mongol

Is that the way to go?

I’ve installed https://atmospherejs.com/msavin/mongol

And I now have access to the mongo db. AFAIK I cannot use javascript though, only JSON.

This should suffice to complete tutorial, but long term I need a better way of working with mongo.

Ideally I would like to get to the bottom of why I cannot work with mongo as described in the tutorial.

I see you’re not using a native Windows shell. There are known issues with MongoDB when sharing folders between OS’s. Try firing up a cmd shell and running meteor mongo from there.

2 Likes

Yes! That was the problem. Thanks for helping me get to the bottom of it. :0)

1 Like

Thank you so much for sharing your solution, Robfallows. It worked for me after I had crisscrossed the entire internet for 2 horrific hours looking for a solution. Gracias.

1 Like