Cannot run my Meteor project

TLDR: When I type “meteor” in the command prompt in Windows 10 I am getting “The system cannot find the path specified.”


I am finishing my Meteor project. I had it on a HDD. Before I have had the Mongo DB corrupted and therefore error during startup. I could resolve the issue by deleting the DB folder, the database was rebuilt then. When I got this error the second time, I thought the reason could be some disk troubles with managing database temp files (chkdsk found some disk errors) and decided to move the project to my SSD (actually the second time the DB problem occurred was after the system restart, so maybe I did not stop the Meteor server first and hence the problem?).

Anyway, I moved the files. But then the ‘meteor’ command started to give “The system cannot find the path specified” error. Now I moved the project back to it’s original location and it’s the same error. Even when I issue ‘meteor’ from it’s native directory “c:\Users\username\AppData\Local.meteor” containing meteor.bat file, the same error occurs.

What could have happened here? How to resolve?

I reinstalled Meteor software with Chocolately and yes, I regained the access to the ‘meteor’ command again.

I deleted the db folder to get rid of the “Unexpected mongo exit code 14.” error.

I managed to run the project.

BUT, it seems corrupted. At least one of the modules that previously existed is missing.

OK, I was able to recover my project.

  1. I created a fresh new project.
  2. I copied to it all JS files from the old.
  3. I replaced in it the file “packages”.
  4. I installed the additional needed module.

And it works.
Still not sure what actually happened, though.