Cannot upgrade to WiredTiger


#1

Hello everyone

Today I upgraded my local app to meteor 1.4.1.1 and everything went fine until I tried to change the mongo storage engine to WiredTiger.

This is what i’ve done so far:
-‘meteor update’ the project (updated successfully to 1.4.1.1)
-‘meteor’ the project (it run without issues)
-make a mongodump of the database (as stated here: Migrating to Meteor 1.4 )
-‘meteor reset’ the project (according to the migration guide, this should suffice to change to WiredTiger on next startup)
-‘meteor’ the project, to run it again and recreate the database.

But then if I do ‘meteor mongo’ and then ‘db.serverStatus().storageEngine’ it outputs:

{ “name” : “mmapv1”, “supportsCommittedReads” : false, “persistent” : true }

Also if I check the mongo version with ‘db.version()’ it outputs:

3.2.6

So mongo appears to have updated successfully to 3.2.6 but I cannot get meteor to recreate the project db with WiredTiger. I tried this a couple of times for good measure but it stays the same.
Also, this might be a stupid question but I cannot find where the mongo executable that meteor uses is located, where can i find it?

Btw, i’m running this on Windows 10

Thanks!


#2

Hi @angryvix - our development MongoDB doesn’t run WT on windows, as it’s a 32 bit binary. You can download and run your own MongoDB binary if you want a WT db locally, or just use WT in production and continue to use mmapv1 for development.


#3

Hi @tmeasday thanks for your reply. Is this mentioned somewhere? Because it seems like important information to state next to the upgrade guide.
Will there be any problems or inconsistencies if I run my dev environment with mmapv1 and prod with WT?

Thanks


#4

Thanks, I updated the guide article.

I’m not entirely sure, but I think you’ll probably only notice differences at scale or under load.