Can't build app on localhost Windows 10 - Process out of memory


#1

Up until now I have only used my imac and my macbook to build my app. I now want to be able to use my Windows pc as well but after 2 days of messing around, I just can’t find a solution. Basically, I am getting this error…

C:\Users\Me\Desktop\myapp>meteor --settings settings-development.json                                             [[[[[ C:\Users\Me\Desktop\myapp]]]]]

=> Started proxy.
=> A patch (Meteor 1.5.4.2) for your current release is available!
   Update this project now with 'meteor update --patch'.
   Linking                                   -
<--- Last few GCs --->

   58416 ms: Mark-sweep 678.5 (734.8) -> 678.5 (734.8) MB, 309.8 / 0 ms [allocation failure] [scavenge might not succeed].
   58824 ms: Mark-sweep 678.5 (734.8) -> 689.2 (734.8) MB, 407.8 / 0 ms [allocation failure] [scavenge might not succeed].
   59177 ms: Mark-sweep 689.2 (734.8) -> 689.0 (734.8) MB, 353.2 / 0 ms [last resort gc].
   59528 ms: Mark-sweep 689.0 (734.8) -> 689.2 (734.8) MB, 351.0 / 0 ms [last resort gc].


<--- JS stacktrace --->

==== JS stack trace =========================================

Security context: 37E25599 <JS Object>
    1: JSONSerialize(aka JSONSerialize) [native json.js:~120] [pc=0DA21153] (this=37E08099 <undefined>,G=37E6D451 <String[4]: data>,j=09243DF1 <an Object with map 2D019699>,v=09243E49 <JS Function replacer (SharedFunctionInfo 2350ECD1)>,w=09243EC9 <JS Array[2]>,x=37E08365 <String[0]: >,y=37E08365 <String[0]: >)
    2: SerializeObject(aka SerializeObject) [native json.js:97] [pc=0DA23534] (this=37E080...

FATAL ERROR: CALL_AND_RETRY_LAST Allocation failed - process out of memory

C:\Users\Me\Desktop\myapp>

Obviously it is related to running out of memory. It always happens when the Linking process is running. What I have gathered from many articles/threads etc. is that I need to set the TOOL_NODE_FLAGS="--max-old-space-size=4096".

For some reason though, after I run set TOOL_NODE_FLAGS="--max-old-space-size=4096", I am no longer able to run ‘meteor run’. the command prompt thinks for a second, and then nothing happens…

So if I run C:\Users\Me\Desktop\myapp>meteor --settings settings-development.json
I get the error above.

If I run C:\Users\Serks\Desktop\cakenote>set TOOL_NODE_FLAGS="--max-old-space-size=4096"
And then run C:\Users\Me\Desktop\myapp>meteor --settings settings-development.json.
Nothing happens and the cursor returns to…`C:\Users\Serks\Desktop\cakenote

Does anyone know how I can get meteor to start with more memory on Windows 10 through cmd line?

Thanks in advance.