Can't deploy to a custom domain on Galaxy


#1

I’m trying to deploy with the following :

DEPLOY_HOSTNAME=galaxy.meteor.com meteor deploy staging.artmeetsapp.com --owner nona --settings settings-staging.json

but each time the container continuously crashes and the logs give me a mongo auth failed error. If I deploy with a free domain and precisely the same settings file it works perfectly. What’s stranger is that I can then add my staging domain to the app in the Galaxy console and that also works.

DEPLOY_HOSTNAME=galaxy.meteor.com meteor deploy artmeetsstage.meteorapp.com --owner nona --settings settings-staging.json

This is also the case if I deploy directly to www.artmeetsapp.com, but again this domain works fine, if I add it after deploying to a free *.meteorapp.com domain.

My Db is hosted on compose.io, which is working well with free domains, and I’m using GoDaddy as my registrar / DNS provider.

To create the sub-domain I added a cname record for ‘staging’ that points to the galaxy load balancer, as well as a cname record for www that points to the load balancer.

Any help would be greatly appreciated.

NB: I began speaking about this in another topic “mongo auth failed” but thought I’d add more detail.


#2

I was being retarded, was simply a typo in my oplog error, when it said there was auth error, there really was one, who new. :confused: